program Geom;
program Test_nn;
{$APPTYPE CONSOLE}
{$R *.res}
uses
Math;
var
a: array of Extended;
n, i, c: Integer;
x: Extended;
begin
Write ('Размерность массива = ');
ReadLn (n);
SetLength (a, n);
Randomize;
for i := Low (a) to High (a) do begin
a [i] := (Random (2001) - 1000) / 1000;
Write (a [i] :7 :3);
end;
x := 1;
c := 1;
WriteLn;
for i := Low (a) to High (a) do begin
if a [i] > 0 then begin
Write (a [i] :7 :3);
x := x * a [i];
Inc (c);
end;
end;
WriteLn;
WriteLn ('Среднее геометрическое = ', Power (x, 1/c) :20 :15);
ReadLn;
end.
№1
упростим данное выражение:
строим таблицу истинности(см. вложение)
№2
ищем среди данных слов такое, у которого первая буква не является гласной и третья не является согласной, то есть слово, у которого первая буква согласная, а третья - гласная
1) Елена - первая буква гласная - е, не подходит
2) Полина - третья буква согласна л, не подходит
3) Кристина - первая буква - согласная и третья буква - гласная, подходит под данное высказывание
4)Анна - первая буква гласная - а, не подходит
ответ: 3
№3
заменим знаки на более удобные:
v - (+)
& - (*)
Слегка сократим данное выражение:
3) +\overline{(x<5)}*(x\leq 8)=(x>3)+(x\geq 5)*(x\leq 8)=\\=(x>3)+(5\leq x \leq 8)\\F=\left[\begin{array}{cc}x>3\\x\in [5;8]\end{array}\right.=x\in(3;+\infty)" class="latex-formula" id="TexFormula2" src="https://tex.z-dn.net/?f=F%3D%28x%3E3%29%20%2B%5Coverline%7B%28x%3C5%29%7D%2A%28x%5Cleq%208%29%3D%28x%3E3%29%2B%28x%5Cgeq%205%29%2A%28x%5Cleq%208%29%3D%5C%5C%3D%28x%3E3%29%2B%285%5Cleq%20x%20%5Cleq%208%29%5C%5CF%3D%5Cleft%5B%5Cbegin%7Barray%7D%7Bcc%7Dx%3E3%5C%5Cx%5Cin%20%5B5%3B8%5D%5Cend%7Barray%7D%5Cright.%3Dx%5Cin%283%3B%2B%5Cinfty%29" title="F=(x>3) +\overline{(x<5)}*(x\leq 8)=(x>3)+(x\geq 5)*(x\leq 8)=\\=(x>3)+(5\leq x \leq 8)\\F=\left[\begin{array}{cc}x>3\\x\in [5;8]\end{array}\right.=x\in(3;+\infty)">
Теперь проверяем, какие x будут принадлежать или не принадлежать полученному промежутку.
ответ: выражение истинно при x=4; x=6, а при x=2; x=3 - ложно.
Поделитесь своими знаниями, ответьте на вопрос:
Впоезде 18 вагонов, в каждом по 36 мест. информация о проданных на поезд билетах хранится в двумерном массиве, номера строк которого соответствуют номерам вагонов, а номера столбцов — номерам мест. если билет на то или иное место продан, то соответствующий элемент массива имеет значение 1, в противном случае — 0. составить программу, определяющую, имеются ли свободные места в том или ином вагоне поезда.