iservice38
?>

Составьте программу паскаль для нахождения всех счастливых автобусных билетов чтобы из низ извлекался квадратный корень

Информатика

Ответы

Yelena_Yuliya1847

Программа, которая сравнивает первые 3 со вторыми 3мя ниже, но я не понял к чему было упоминание корня в первоначальном задании

Program bilet;
var

a,b,c:longint;
i:byte;
begin
writeln('vvrdite nomer');
readln(a);
b:=0;
c:=0;
for i:=1 to 6 do
    if i<4 then begin
       b:=b+(a mod 10);
       a:=a div 10;
       end
    else begin
         c:=c+(a mod 10);
         a:=a div 10;
    end;
if b=c then writeln('schastlivuy ',c,' = ',b)
else writeln('uvyu ',c,' <> ',b);
readln;
end.

Тимур Андраниковна634
Var a1, b1, c1, a2, b2, c2, p1, p2, s1, s2: real;
begin
  writeln('Введите строны первого треугольника: ');
  read(a1, b1, c1);
  writeln('Введите стороны второго треугольника: ');
  read(a2, b2, c2);
  p1 := (a1 + b1 + c1) / 2;
  p2 := (a2 + b2 + c2) / 2;
  s1 := sqrt(p1 * (p1 - a1) * (p1 - b1) * (p1 - c1));
  s2 := sqrt(p2 * (p2 - a2) * (p2 - b2) * (p2 - c2));
  if (s1 + 1e-3 > s2) and (s1 < s2 + 1e-3) then writeln('Равновеликие')
                                           else writeln('Неравновеликие');
end.
ella-rudenko

В n будем хранить количество чисел, которые ещё нужно вывести. a и b - предыдущее и текущее числа Фибоначчи. По определению, следующее число Фибоначчи равно сумме двух предыдущих, так что новое значение b будет a + b. Чтобы не заводить новую временную переменную, новое значение a можно будет найти, вычитая из нового b старое a, получится (a + b) - a = b.

Код процедуры:

procedure print_fib(n: integer);

var a, b, t: integer;

begin

   a := 0;

   b := 1;

   while n > 0 do

   begin

       write(b, ' ');

       b := a + b;

       a := b - a;

       n := n - 1;

   end;

end;

Пример основной программы:

begin

   print_fib(10)

end.

Вывод:

1 1 2 3 5 8 13 21 34 55

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу паскаль для нахождения всех счастливых автобусных билетов чтобы из низ извлекался квадратный корень
Ваше имя (никнейм)*
Email*
Комментарий*