PivovarovaIlina1437
?>

На завтра нужно ! ) напишите программу, вычисляющую сумму только тех из введенных чисел, которые делятся нацело на 6.

Информатика

Ответы

dentob72
Var a,i,n,s: integer; begin write('сколько чисел будет введено? - '); readln(n); s: =0; for i: = 1 to n do begin   readln(a);   if a mod 6=0 then s: =s+a; end; writeln('сумма чисел кратных 6 = ', s); end.
Albina

program yravnenie;

var  a,b,c,d,x1,x2,p,q: real; begin  repeat  write('a= ');   readln(a);   if a=0 then writeln('error: a=0. enter another value');   until a< > 0;   write('b= ');   readln(b);   write('c= ');   readln(c);   p: =b/a;   q: =c/a;   d: =sqr(p/2)-q;   if d> 0 then  begin    writeln('x1 = ',-p/2-sqrt(d): 0: 5);     writeln('x2 = ',-p/2+sqrt(d): 0: 5);   end  else  if d=0 then  writeln('x1 = x2 = ',-p/2: 0: 5)  else  begin    writeln('x1 = ',-p/2: 0: 5,'-i*',sqrt(-d): 0: 5);     writeln('x2 = ',-p/2: 0: 5,'+i*',sqrt(-d): 0: 5);   end;   readln; end.

misie1974

1)

высказывание   не (не  а  и  b)  будет ложным когда высказывание

(не  а  и  b)   будет истинным, оно в свою очередь будет истинным когда

будут истинны одновременно высказывание  не  а  и   высказывание  b

то есть когда а ложное а в истинное

2)

число 376 трехзначное и четное

а=число 376 трехзначное

в=число 376 четное

а и в

или

если сумма цифр числа делится на 3, то число делится  на  3

а=сумма цифр числа делится на 3

в=число делится  на  3

если а то в

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На завтра нужно ! ) напишите программу, вычисляющую сумму только тех из введенных чисел, которые делятся нацело на 6.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

О. Карпов1691
Dmitrievich1871
Баканова1415
Zashchitin Denis
vitaldicky349
NurlanAleksandrovich
Aleksandr
chaa140
musaevartur
saryba
tatianaesipenko
info9
extremhunter
burtsev3339
anadtacia03108988