Const n = 10; type vector = array[1..n] of integer; function sumdig(a: vector): integer; var i, m, d, s, max: integer; begin s : = 0; for i : = 1 to n do begin m : = a[i]; max : = -1; repeat d : = (m mod 10); if max < d then max : = d; m : = m div 10 until m = 0; s : = s + max end; sumdig : = s end; var i: integer; m: vector; begin writeln('введите ', n, ' чисел: '); for i : = 1 to n do read(m[i]); writeln('сумма максимальных цифр всех чисел равна ', sumdig(m)) end. тестовое решение: введите 10 чисел: 613 269 839 10 575 569 812 56 401 616 сумма максимальных цифр всех чисел равна 65
karpachevamarina
08.02.2023
№| название | место расположения | площадь, км21 каспийское море |самое большое на земле озеро, бессточное, расположенное на стыке европы и азии| 371 000 км² 2 верхнее | одно их больших озер северной америки |82 103 км² 3 виктория | озеро в восточной африке, на территории танзании, кении и уганды. расположено в тектоническом прогибе | 68 800 км² 4 гурон |озеро в сша и канаде | 59 600 км² 5 мичиган | пресноводное озеро в сша| 58 000 км² 6 аральское море | бывшее бессточное соленое озеро в средней азии| 3 300 км² 7 танганьика | крупное озеро в центральной африке| 32 900 км² 8 байкал |озеро тектонического происхождения в южной части восточной сибири| 31 722 км² 9 большое медвежье |находится на севере канады| 31 153 км² 10 нуаза | озеро (нуаза) малави - самое южное из так называемых великих африканских озер восточно-африканской рифтовой зоны| 6 400км²
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Написать программу, которая выводит квадраты двузначных чисел а)цикл for b) цикл while c) цикл repeat
или цикл for или цикл while