Вадим-Рашад323
?>

Напишите программу на авс паскаль .net которая определяет является ли число х трёхзначным и чётным

Информатика

Ответы

Есартия52

ответ:

var x: integer;

begin

read(x);

if (x< 1000 and x> 99 and x mod 2=0) then write('является')

else write('не является');

end;

Georgievich-Zamudinovna2003

1)

program z1;

var x,y: integer;

begin

write ('x = ');

readln (x);

write ('y = ');

readln (y);

if (y>0) and (x*x+y*y<4) then writeln('Точка попадает в синюю область')

else writeln('Точка не попадает в синюю область')

end.

2)

program z1;

var x,y: integer;

begin

write ('x = ');

readln (x);

write ('y = ');

readln (y);

if (x<0) and(y<0) and (x*x+y*y<5) then writeln('Точка попадает в синюю область')

else writeln('Точка не попадает в синюю область')

end.

Объяснение:

Проекции точки на оси x и y являются катетами прямоугольного треугольника. Гипотенуза - расстояние от начала координат до точки.

Чтобы точка принадлежала кругу расстояние до точки должно быть меньше радиуса.

Поскольку здесь половина и четверть круга, добавляем ограничения по х и у.

mary---jane49

Ақпарат (лат. informatio — түсіндіру, мазмұндау) ұғымы күнделікті өмірден бастап техникалық салада пайдаланылатын көп мағыналы ұғым. Жалпы алғанда бұл ұғым шектеу, байланыс, бақылау, форма, инструкция, білiм, мағына, құрылым, бейнелеу, сезіну тағы басқа ұғымдармен тығыз байланысты. Көп адам бұл жайлы Білім дәуірі немесе білім қоғамы тудырған Ақпарат дәуірі туралы айта бастады; ақпараттық қоғам, ақпараттық технологиялар, тіпті информатика, ақпарат ғылымы және компьютер ғылымы назарға көп түсуде, ал “ақпарат” сөзі білдіре бастаған мағыналары ұқыпсыз пайдаланылуда.[1]

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу на авс паскаль .net которая определяет является ли число х трёхзначным и чётным
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Александровна1742
тахирович_Игорь581
dianabuchkina
milkiev
Александр Елена1290
Информатика 8 класс. Програмир.
shajmasha
galiyamart6671
avto3132
martinson
vkurnosov20008
megaromeo
ninakucherowa
Batishcheva
VladimirovichKazakova1202
Lianchikavon