Составьте программу , которая рисует отрезок с координатами концов (100, , 200), если введено число 1 , и рисует окружность с центром (200, 100) и радиусом 50, если введено число 2.
Uses crt,graph; var n: integer; procedure init; var gd,gm: integer; begin gd: =vga; gm: =vgahi; initgraph (gd,gm,''); end; procedure error; begin closegraph; writeln ('error! '); end; begin write ('number: '); readln (n); init; if graphresult=0 then begin if n=1 then line(100,100,100,200) else if n=2 then circle(200,100,50); end else error; end.
textildlavas21
30.04.2020
Паскаль (pascal) блез (1623-62), один из самых знаменитых людей в человечества, французский , , религиозный философ и писатель. сформулировал одну из основных теорем проективной . работы по арифметике, теории чисел, , теории вероятностей. сконструировал (1641 — 1642) суммирующую машину. один из основоположников гидростатики, установил ее основной закон, названный его именем. весьма религиозный человек, придерживался течения янсенизма, с 1655 вел полумонашеский образ жизни. полемика с иезуитами отразилась в “письмах к провинциалу” (1656-57) — шедевре французской сатирической прозы. в “мыслях” (опубликованы в 1669) паскаль развивает представление о трагичности и хрупкости человека, находящегося между двумя безднами — бесконечностью и ничтожеством (человек — “мыслящий тростник”). путь постижения тайн бытия и спасения человека от отчаяния видел в христианстве. сыграл значительную роль в формировании французской классической прозы. в 1642 году французский блез паскаль «повторил» изобретение в. шикарда. его счетное устройство вошло в с именем «паскалево колесо», или «паскалина». это был ящик с многочисленными шестеренками. при работе на «паскалине» складываемые числа вводились путем соответствующего поворота наборных колесиков. паскаль всю жизнь работал над совершенствованием своего аппарата и построил более 50 различных его вариантов. а принцип, который он использовал в своих первых арифмометрах, стал основой, на которой строилось большинство вычислительных устройств на протяжении следующих трех столетий. заслуга была достойно отмечена — в 1649 году паскаль получил королевскую привилегию на изготовление и продажу своей машины. надёжность в вычислениях и работе - главный критерий устройства, потому что даже до наших дней сохранилось восемь рабочих машин. популярность и необычность их была такова, что им посвящались
secretary
30.04.2020
Практически во всех операционных системах имя файла составляется из двух частей, разделенных точкой. например: myprog.pas слева от точки находится собственно имя файла (ту-prog). следующая за точкой часть имени называется расширением файла (pas). обычно в именах файлов употребляются латинские буквы и цифры. в большинстве ос максимальная длина расширения - 3 символа. кроме того, имя файла может и не иметь расширения. в операционной системе windows в именах файлов допускается использование букв; максимальная длина имени - 255 символов.расширение указывает, какого рода информация хранится в данном файле. например, расширение txt обычно обозначает текстовый файл (содержит текст); расширение рсх - графический файл (содержит рисунок), zip или гаг - архивный файл (содержит архив - сжатую информацию), pas - программу на языке паскаль. файлы, содержащие выполнимые компьютерные программы, имеют расширения ехе или com.удачи!
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Составьте программу , которая рисует отрезок с координатами концов (100, , 200), если введено число 1 , и рисует окружность с центром (200, 100) и радиусом 50, если введено число 2.