Написать программу, определяющую состоит ли трехзначное число из одинаковых цифр. подсказка: в материалах урока есть программа по определению цифр в двузначном числе!
Var n: integer; begin write('введите трехзначное число: '); readln(n); if (n mod 10 = n div 100) and (n mod 10=n mod 100 div 10) then writeln('да') else writeln('нет'); end.
Yurevich
05.09.2021
1. современное решение // pascalabc.net 3.2, сборка 1417 от 28.03.2017 // внимание! если программа не работает, обновите версию! begin var s: =readlnstring('введите строку: ').select(c-> lowcase(c)); var nd: =s.groupby(c-> c).select(c-> (c.key,c.(kv-> kv[0]); var n: =nd.count; nd.select(kv-> (kv[0],kv[1]/(kv-> writeln(kv[0],' : ',kv[1]: 5: 3)) end. пример работы введите строку: в чащах юга жил бы цитрус? да, но фальшивый экземпляръ! : 0.250 ! : 0.028 , : 0.028 ? : 0.028 а : 0.139 б : 0.028 в : 0.056 г : 0.028 д : 0.028 е : 0.028 ж : 0.028 з : 0.028 и : 0.083 й : 0.028 к : 0.028 л : 0.083 м : 0.028 н : 0.028 о : 0.028 п : 0.028 р : 0.056 с : 0.028 т : 0.028 у : 0.028 ф : 0.028 х : 0.028 ц : 0.028 ч : 0.028 ш : 0.028 щ : 0.028 ъ : 0.028 ы : 0.056 ь : 0.028 э : 0.028 ю : 0.028 я : 0.028 2. школьное решение в стиле турбопаскаль 1983г. uses crt; const uc: string[33]='абвгдеёжзийклмнопрстуфхцчшщъыъэюя'; lc: string[33]='абвгдеёжзийклмнопрстуфхцчшщъыьэюя'; var s: string; i,n,k,p: integer; mc: array[1..255] of char; mn: array[1..255] of byte; c: char; begin clrscr; write('введите строку: '); readln(s); n: =length(s); for i: =1 to 255 do mn[i]: =0; k: =0; for i: =1 to n do begin c: =s[i]; p: =pos(c,uc); if p> 0 then c: =lc[p]; p: =ord(c); if mn[p]=0 then begin mc[p]: =s[i]; mn[p]: =1; k: =k+1 end else mn[p]: =mn[p]+1 end; for i: =1 to 255 do if mn[i]< > 0 then writeln(mc[i],' : ',mn[i]/k: 5: 3); readkey end.
kabanovae
05.09.2021
Const n = 13; var a: array[1..n] of integer; i,max,min,s: integer; begin randomize; write('исходный массив a(',n,'): '); min: =1; max: =1; for i: = 1 to n do begin a[i]: =random(201)-100; write(' ',a[i]); if a[i]< a[min] then min: =i; if a[i]> a[max] then max: =i; s: =s+a[i]; end; writeln; writeln('min(a) = a[',min,'] = ',a[min]); writeln('max(a) = a[',max,'] = ',a[max]); writeln('среднее арифметическое элементов массива = ',s/n); write('новый массив: '); s: =a[min]; a[min]: =a[max]; a[max]: =s; for i: = 1 to n do write(' ',a[i]) end. пример работы программы: исходный массив a(13): 60 -61 8 -60 58 -73 93 82 74 -35 89 -72 -44 min(a) = a[6] = -73 max(a) = a[7] = 93 среднее арифметическое элементов массива = 9.15384615384615 новый массив: 60 -61 8 -60 58 93 -73 82 74 -35 89 -72 -44
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Написать программу, определяющую состоит ли трехзначное число из одинаковых цифр. подсказка: в материалах урока есть программа по определению цифр в двузначном числе!