Напишите программу печатающую на экране заданное число и четыре предыдущих нечетных числа.в качестве входных данных допускается задавать число от 10 до1000
Везде значения вводятся с клавиатуры! на java если изучали массив: public class qwert { public static void main(string args[]) { scanner scn = new scanner(system.in); int[] a = new int[5]; int k = 0; for (int i = 0; i < 5; i++) { a[i] = scn.nextint(); k = k + a[i]; if (i == 4) system.out.println(k/i); } } }если не изучали массив: public class qwert {public static void main(string args[]) { scanner scn = new scanner(system.in); int a = scn.nextint(); int b = scn.nextint(); int c = scn.nextint(); int d = scn.nextint(); int e = scn.nextint(); int s = (a + b + c + d + e) / 5; system.out.println(s); }}на паскале через массив: var a: array [1..5] of integer; i: integer; s: real; beginfor i : = 1 to 5 dobeginreadln(a[i]); s : = s + a[i]; if i = 5thenwrite (s/i); end; end.не через масивы: var a,b,c,d,e : integer; s: real; beginreadln(a,b,c,d,e); s : = (a+b+c+d+e)/5; write(s); end.
emik071089
02.01.2022
const n = 13; var a : array [1..n] of integer; i,k : integer; begin randomize; for i : = 1 to n do a[i] : = -200 + random(301); k : = 0; for i : = 1 to n do if (a[i]< -7) and (a[i]> -20) then k : = k +1; writeln (k); end.