Ubuleeva826
?>

Дана последовательность целых чисел а1, . верно элементы последовательности равны собой.нужно написать программу на паскале с циклом

Информатика

Ответы

dilshermatov5806
Var a: array [1..20] of integer;     i: integer; begin       for i : = 1 to 20 do           readln(a[i]);       for i : = 1 to 20 do           if (a[i] < > a[1]) then           begin               writeln('неверно');               exit;           end;       writeln('верно'); end.надеюсь, я правильно понял , а то иногда не тут вначале надо 20 чисел ввести, а потом она проверяет, верно ли, что они все равны)
avtalux527
Var a: array of integer; var i: byte; var b: boolean; begin b: =true; setlength(a,8); var n: =0; writeln('введите число: '); readln(i); var d: =i; while i< > 0 do begin a[n]: =i mod 2; i: =i div 2; inc(n); end; setlength(a,n); for   i: =0 to n-1 do begin if n=0 then begin write(0); break; end; swap(a[i],a[n-1]); write(a[i]); end; for i: =1 to n-1 do begin if n=0 then break; if a[i-1]< > a[i] then begin b: =false; break; end; end; if (b=false) then write(' = ',d,' это не палиндром') else  write(' = ',d,' это палиндром'); end.
mouse-0211fsb3509
Вданной программе при запуске надо ввести одно число. после чего выводится 10 чисел от 9 до заданного не включительно. например, при вводе числа 20, выведутся числа от 10 до 19. #include < iostream> #include < time.h> using namespace std; int main ()  {     srand(time(null));     int a;     cin > > a;     for (int i=0; i< 10; i++) {           cout < < rand() % (a-10) +10;     }     return 0; }

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дана последовательность целых чисел а1, . верно элементы последовательности равны собой.нужно написать программу на паскале с циклом
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

PopovViktorovna
ИринаАлександровна
Федорович Шахова241
re-art
Vyacheslavovna240
Valentinovna
Aleksandrovich-Mayatskikh
Курнев-Анастасия359
rashodnikoff
elenakarpova709
Amelin-Alipova
voropayelena26
kristal1
Ахади
valerii-borisovich550