kazimov832
?>

Сpascal! - составьте программу нахождения суммы n произвольных чисел(число n ввести с клавиатуры

Информатика

Ответы

Novikova
Много вариантов написания программы. например, нужны ли массивы? вот простой пример без массива, где пользователь задает кол-во чисел и вводит их поочередно:
Strelkov567
Var a,b,c: real; begin write('введите длину стороны a: '); readln(a); ' write('введите длину стороны b: '); readln(b); write('введите длину стороны c: '); readln(c); if (a+b < =c) or (b+c < = a) or (c+a < = b) then writeln('треугольника с такими сторонами не существует! ') else begin if (sqr(a)+sqr(b)> sqr(c))and(sqr(b)+sqr(c)> sqr(a))and(sqr(c)+sqr(a)> sqr(b)) then writeln('треугольник остроугольный') else if (sqr(a)+sqr(b)=sqr(c))and(sqr(b)+sqr(c)=sqr(a))and(sqr(c)+sqr(a)=sqr(b)) then writeln('треугольник прямоугольный') else writeln('треугольник тупоугольный'); end; end. объяснение, если a,b,c длины сторон теугольника, то a+b> c, b+c> a, c+a> b по теореме косинусов a^2+b^2-2abcos(c)=c^2? отсюда если угол c < 90? то cos(c)> 0 поэтому a^2+b^2> c^2
Dlyamila

Если вы не знакомы с Excel в Интернете, вы вскоре увидите, что это не сетка, в которой вы вводите числа в столбцах или строках. Да, вы можете использовать Excel в Интернете для поиска итогов по столбцу или строке чисел, но вы также можете рассчитать оплату по закладной, решить проблемы математических или инженерных решений или найти наиболее подходящую ситуацию на основе переменных, которые вы подключаетесь.

Excel в Интернете делает это с формул в ячейках. Формула выполняет вычисления или другие действия с данными на листе. Формула всегда начинается со знака равенства (=), за которым могут следовать числа, математические операторы (например, знак "плюс" или "минус") и функции, которые значительно расширяют возможности формулы.

Ниже приведен пример формулы, умножающей 2 на 3 и прибавляющей к результату 5, чтобы получить 11.

=2*3+5

Следующая формула использует функцию ПЛТ для вычисления платежа по ипотеке (1 073,64 долларов США) с 5% ставкой (5% разделить на 12 месяцев равняется ежемесячному проценту) на период в 30 лет (360 месяцев) с займом на сумму 200 000 долларов:

=ПЛТ(0,05/12;360;200000)

Ниже приведены примеры формул, которые можно использовать на листах.

=A1+A2+A3    Вычисляет сумму значений в ячейках A1, A2 и A3.

=КОРЕНЬ(A1)    Использует функцию КОРЕНЬ для возврата значения квадратного корня числа в ячейке A1.

=СЕГОДНЯ()    Возвращает текущую дату.

=ПРОПИСН("привет")     Преобразует текст "привет" в "ПРИВЕТ" с функции ПРОПИСН.

=ЕСЛИ(A1>0)    Анализирует ячейку A1 и проверяет, превышает ли значение в ней нуль.

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Сpascal! - составьте программу нахождения суммы n произвольных чисел(число n ввести с клавиатуры
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Petrovich
katdavidova91
Aleksandrovich-Yurevna1421
s-shulga
evatautes
vdm4275
Bogdanov
Вера1072
alplakhota67
starabanov
ИгоревичАндрей
samsludmila
milenaochirova01017424
len22
Петренко1852