d892644813661946
?>

Нужно написать программу. заданы величины x, y действительного типа. написать программу обмена значений величин.использовать величины нельзя.

Информатика

Ответы

olgalooo
Var  x,y: real;   begin  readln(x);   readln(y);   x: =x+y;   y: =x-y;   x: =x-y;   write('x='); writeln(x);   write('y='); writeln(y);
Vs1377

program kontr;

var a,b: integer;

      c: char;

      n,m: string;

begin

writeln ('введите первую цифру');

readln(a);

writeln ('введите вторую цифру');

readln(b);

writeln ('введите один из знаков: +*,/');

readln(c);

case a of

0: n: ='ноль';

1: n: ='один';

2: n: ='два';

3: n: ='три';

4: n: ='четыре';

5: n: ='пять';

6: n: ='шесть';

7: n: ='семь';

8: n: ='восемь';

9: n: ='девять';

end;

case b of

0: m: ='ноль';

1: m: ='один';

2: m: ='два';

3: m: ='три';

4: m: ='четыре';

5: m: ='пять';

6: m: ='шесть';

7: m: ='семь';

8: m: ='восемь';

9: m: ='девять';

end;

 

case c of

'*': writeln (n,' умножить на ',m);

'/': writeln (n,' разделить на ',m);

'+': writeln (n,' плюс ',m);

'-': writeln (n,' минус ',m);

end;

end.

gulnaradjhumabaeva123
#include < iostream> using namespace std; string evenorodd(int n) { if (n % 2 == 0) { return "чётное"; } else { return "нечётное"; } } string digitcount(int n) { if ( (int) n / 1000 > 0 ) { if (n > 9999){ return "n-значное"; } else { return "четырёхзначное"; } } else if ( (int) n % 1000 / 100 > 0 ) { return "трёхзначное"; } else if ( (int) n % 100 / 10 > 0 ) { return "двузначное"; } else { return "однозначное"; } } int main() { int n; cout < < "n = "; cin > > n; cout < < evenorodd(n) < < ' ' < < digitcount(n) < < ' ' < < "число" < < endl; return 0; }

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно написать программу. заданы величины x, y действительного типа. написать программу обмена значений величин.использовать величины нельзя.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Мария
galkar
dakimov
vikabobkova2010
Lidburg
DVOct33
brand
Dms161964937
nusupova
Lolira64
Морозов
Ирина
mariy-inkina8
ver2bit
davidovalbert6