appmicom
?>

Напишите программу в паскале (решение): известна масса каждого человека из группы. верно ли, что масса самого тяжелого из них превышает массу самого легкого более чем в 2 раза?

Информатика

Ответы

Suralevartem

var min,max: integer;

a: real;

begin

write("vvedite massi vseh ludei iz gruppy: ");

read(a);

min: =a;

while (a> 0) do

begin

read(a);

if (a> max) max: =a;

if (a< min) min: =a;

end;

a: =max/min;

if (a> 2) then write("verno") else write("neverno");

readln

end.

 

oskina3
Формализованный  (формальный)  язык –– язык, характеризующийся точными правилами построения выражений и их понимания. он строится в соответствии с четкими правилами, обеспечивая непротиворечивое, точное и компактное отображение свойств и отношений изучаемой предметной области (моделируемых объектов).в отличие от естественных языков формальным языкам присущи четко сформулированные правила семантической интерпретации и синтаксического преобразования используемых знаков, а также то, что смысл и значение знаков не изменяется в зависимости от каких-либо прагматических обстоятельств (например, от контекста). большинство формальных языков (созданных конструкций) строится по следующей схеме. сначала выбирается  алфавит, или совокупность исходных символов, из которых будут строиться все выражения языка; затем описывается  синтаксисязыка, то есть правила построения осмысленных выражений. буквами в алфавите формального языка могут быть и буквы алфавитов естественных языков, и скобки, и специальные знаки и т.п. из букв, по определенным правилам можно составлять  слова и выражения. осмысленные выражения получаются в формальном языке, только если соблюдены определенные в языке  правила  образования. для каждого формального языка совокупность этих правил должна быть строго определена и модификация любого из них приводит чаще всего к появлению новой разновидности (диалекта) этого языка.формальные языки широко применяются в науке и технике. в процессе научного исследования и практической деятельности формальные языки обычно используются в тесной взаимосвязи с естественным языком, поскольку последний обладает гораздо большими выразительными возможностями. в то же время формальный язык является средством более точного представления знаний, чем естественный язык, а следовательно, средством более точного и объективного обмена информацией между людьми.формальные языки часто конструируются на базе языка . веком бурного развития различных формальных языков можно считать xx век. с точки зрения информатики, среди формальных языков наиболее значительную роль играют формальный  язык логики(язык логики) и  языки программирования.
mrFuz
Пусть видеопамять компьютера имеет объем 512 кбайт. размер графической сетки - 640 х 480. сколько страниц экрана одновременно разместится в видеопамяти при палитре из 16 цветов; 256 цветов?   для 16 (2^4) цветов нужно 4 бита на пиксель, для одного экрана нужно 640*480*4=1228800 бит=153600 байт, память 512*1024=524288 байт, посчитаем 524288 /153600=3,41333 т.е. 3 страницы.  для 256 (2^8) цветов нужно 8 бит на пиксель, для одного экрана нужно 640*480*8=2457600 бит=307200 байт, память 512*1024=524288 байт524288 /307200=1,70667 т.е. 1 страница.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу в паскале (решение): известна масса каждого человека из группы. верно ли, что масса самого тяжелого из них превышает массу самого легкого более чем в 2 раза?
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

fotomuha1
xsmall1
КузменковаЖигулин
Yelfimova-andrei
oknacrow
oslopovavera
helenavalenti2846
Ingakazakova
АлексейГагиковна1774
dashanna04225
Nazart44446
Chutaeva381
akustov55
soclive7762
Kondratev Ruzavina22