sanyaborisov910067
?>

1.составить программу вывода на экран квадрата числа, если число отрицательное, и куба если число положительное. 2. составить программу вывода на экран чисел от 1 до 50. программа на язеке паскаля

Информатика

Ответы

peresvetoff100015
Var i: integer; begin readln(i); if i> 0 then begin writeln(i*i*i); end else begin writeln(i*i); end; end. var i: integer; begin for i=1 to 50 do begin writeln(i); end; end.
Zukhra Andreevich1040
1.var a,b,c: integer; begin read(a); if a< 0 then a: =a*a else a: =a*a*a; writeln(a) end. 2.var a,b,c: integer; beginfor c: =1 to 50 dowrite(c,' '); end.
SEMENOV25352
Program project1; usescrt,math; constn=3; var    s: real;     i,j,f: byte;     a: array [1..n, 1..n] of integer; begin    for i: =1 to n do    begin    for j: =1 to n do  begin    write('vvedite ',i,'.',j,' cifru '); readln(a[i,j]);     end;     end;   for i: =1 to n do    begin    for j: =1 to n do  begin    if (a[i,3]=1) then  inc(f);     end;     end;   writeln('1 vstrechaetsya: ',f: 2,' raz');   readln; end.
qwert28027170
)в числе не меньше двух цифр, которые меньше шести. следовательно, в числе две цифры в диапазоне от 0 до 5, а третья может быть и больше. 2) в числе не меньше двух четных цифр. следовательно, в числе одно цифра может быть и нечетной. 3) если число должно быть наибольшим, то его старшая цифра должна быть не меньше остальных. учитывая 1) и 2) выбираем в качестве старшей цифры девятку. тогда две оставшиеся меньше шести и обе четные. 4) с учетом того, что число должно быть наибольшим, выберем цифры четыре. ответ: 944

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1.составить программу вывода на экран квадрата числа, если число отрицательное, и куба если число положительное. 2. составить программу вывода на экран чисел от 1 до 50. программа на язеке паскаля
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vifslafes
Марюк-Мубариз
tata-novik
studiojanara
astahova
katyn76
konnovakat1
olartamonov6
postbox
ckati
guujuu
info7
kirillprotopopov1
sashab82
firsova5911