VadimovnaIgor
?>

Напишите программу в паскале и объясните, как это делается сложить два 15-ти значных целых числа. при этом используют тип integer. т.е. реализовать поэлементное сложение значений двух массивов с переносом разряда.

Информатика

Ответы

N-odes-art-school410
Const n=15; var a,b,c: array[0..n] of integer; s_a,s_b: string; i: integer; begin   readln(s_a);   readln(s_b);   while length(s_a)< n do s_a: ='0'+s_a;   while length(s_b)< n do s_b: ='0'+s_b;     for i : = n downto 1 do begin       a[i]: =strtoint(s_a[i]);       b[i]: =strtoint(s_b[i]);       c[i]: =c[i]+a[i] + b[i];       c[i-1]: =c[i] div 10;       c[i]: =c[i] mod 10;   end;   writeln;   for i: = 0 to n do write(a[i]);   writeln;   for i: = 0 to n do write(b[i]);   writeln;   for i: = 0 to n do write(c[i]); end.
виталийВячеславович

Интернет-зависимость – это расстройство в психике, сопровождающееся большим количеством поведенческих проблем и в общем заключающееся в не человека вовремя выйти из сети, а также в постоянном присутствии навязчивого желания туда войти.Зависимый  от интернета человек не может вовремя выйти из онлайн среды и постоянно стремится туда вернуться. Люди, которые страдают интернет-зависимостью, очень часто ищут в нем утешение, для них интернет — это доступ в фантастический виртуальный мир, где они могут свободно общаться, быть собой, или же наоборот примерять на себя разные роли, быть тем, кем хочется быть в реальном мире. Если человеку не хватает общения в реальной жизни, он может прибегнуть к интернету, который сможет сделать для него более доступными межличностные отношения.симптомы интернет-зависимости:

Желание постоянно пользоваться интернетом;Потеря интереса к реальной деятельности; более сильное воздействие виртуальных новостей (отзывов, сообщений и т.д.) на психологическое состояние человека по сравнению с событиями реальной жизни. Вы ощущаете огромную радость перед каждым новым сеансом, а без доступа в интернет испытываете грусть и уныние;Низкая сосредоточенность на любом деле. Во время интернет-серфинга забываете о служебных обязанностях, учебе, домашних делах, встречах и договоренностях;Потеря чувства времени;Постоянно проверяете новостные и информационно-развлекательные сайты, обновляете почту, новостную ленту и аккаунты;Возникают трудности взаимодействия с реальным миром (потеря живого контакта с друзьями и родными);Постоянно возрастающий уровень социальной тревоги;Нарушение сна и плохое самочувствие;Забывчивость.

nailboxru

#include <bits/stdc++.h>

using namespace std;

int main(){

int n, negativeIndex = 0, positiveIndex = 0, buf = 0;

bool a, b = false;

cin >> n;

int arr[n];

for(int i = 0; i < n; ++i){

 cin >> arr[i];

}

for(int i = 0; i < n; ++i){

 if(arr[i] < 0){

  negativeIndex = i;

  a = true;

  break;  

 }

}

for(int i = n-1; i >= 0; --i){

 if(arr[i] >= 0)

  positiveIndex = i;

  b = true;

  break;

}

if(a && b){

buf = arr[negativeIndex];

arr[negativeIndex] = arr[positiveIndex];

arr[positiveIndex] = buf;

}

for(int i = 0; i < n; ++i){

 cout << arr[i] << "\t";

}

return 0;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу в паскале и объясните, как это делается сложить два 15-ти значных целых числа. при этом используют тип integer. т.е. реализовать поэлементное сложение значений двух массивов с переносом разряда.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

parolmm
Valentina1520
Olegmgu11986
Виктория1690
ekaizer
serebrennikova99
X2755070
Чечин-Павлова615
Компютермен жжұмыс істеңіз​
rublevaoe392
Avolohova
BelyaevNadezhda223
Потапова 79275136869323
nikdenly
expozition
ars-trushakova
▲