Sergei1198
?>

Дано целое число а, если значение а> 0, то необходимо увеличить его на единицу. написать программу для решения этой .

Информатика

Ответы

mayorovmisc6
Uses crt; var a: integer; begin readln(a); if a> 0 then inc(a); writeln(a); end.
marat-dzhanibekov

6

Объяснение:

Левая граница уже в двоичной системе, переводим правую границу. Она представлена в 16-ричной системе счисления, поэтому можно просто по таблице перевести каждую 16-ричную цифру в 4 двоичные:

CA₁₆ = 1100 1010₂

Если для целых a и b нужно посчитать количество целых чисел x, удовлетворяющих неравенству a < x < b, достаточно посчитать b - a - 1 (пример: 0 < x < 1 - 0 чисел). Если ответ получится отрицательный, ответ будет 0.

1100 1010₂ - 1100 0011₂ - 1 = 1010₂ - 0011₂ - 1 = 10₁₀ - 3 - 1 = 6

anytkaakk

1.

program qq;

const n = 10;

var a: array[1..n] of integer;

i,k: integer;

begin

randomize;

for i: =1 to n do

begin

a[i]: =random(2001)+1000;

write(a[i],' ');

end;

writeln;

k: =0;

for i: =1 to n do

if a[i] mod 3 = 0 then k: =k+1;

writeln('количество элемениов кратных 3 - ', k);

readln;

end.

пример:

2296 2042 2463 2049 1081 2156 2977 1633 1054 1425  

количество элемениов кратных 3 - 3

2. определяется количество чисел, которые при делении на 10 остаток 8.

program qq;

const n = 10;

var a: array[1..n] of integer;

i,k: integer;

begin

randomize;

for i: =1 to n do

begin

a[i]: =random(2001)+1000;

write(a[i],' ');

end;

writeln;

k: =0;

for i: =1 to n do

if a[i] mod 10 = 8 then k: =k+1;

writeln('k = ', k);

readln;

end.

пример:

1887 1878 2568 1936 2508 2788 2050 1569 2906 1782  

k = 4

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дано целое число а, если значение а> 0, то необходимо увеличить его на единицу. написать программу для решения этой .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ВасильевнаСергей
airon-082054
Veselova
verakmves
Mikhail579
sotrudnik3
Negutsa_Kseniya524
ccc712835
lyubavalev8
GoncharenkoKuzmin
Mexx9050
VSArsentev
snabomp
Mariya Filippov
tpomyleva6