Var sum, count, t : integer; begin sum : = 0; count : = 0; while not eoln do begin read (t); if t > 0 then begin sum : = sum + t; count : = count + 1; end; writeln (sum, ' ', count); end. если количество элементов указано var sum, count, t, n, i : integer; begin sum : = 0; count : = 0; read (n); for i : = 1 to n do begin read (t); if t > 0 then begin sum : = sum + t; count : = count + 1; end; writeln (sum, ' ', count); end.
lbondareva
20.08.2020
Измените тип переменных n и k на integer: function xfact(o: integer): integer; var factorial: longint; i: integer; begin write('o = '); readln(o); factorial : = 1; for i : = 2 to o do factorial : = factorial * i; end; var c: real; n,k: integer; begin writeln('введите число n: '); readln(n); writeln('введите число k: '); readln(k); c : = xfact(n) / xfact(n - k) * xfact(k); writeln('c = ', c); end.
verachus
20.08.2020
1. var a,b,c: integer; begin write('введите а, в, с: '); readln(a,b,c); if abs(a+b+c)> 3 then write('их абсолютное значение суммы больше трёх. уменьшаю на 1 каждое число - ',a,'-1 = ',a-1,', ',b,'-1 = ',b-1,', ',c,'-1 = ',c-1) else write('их абсолютное значение суммы не превышает трёх. показываю квадраты этих чисел - ',a,'^2 = ',sqr(a),', ',b,'^2 = ',sqr(b),', ',c,'^2 = ',sqr(c)); end. 2. var r,a: integer; begin write('введите радиус круга '); readln(r); write('введите сторону квадрата '); readln(a); writeln('s круга = ',sqr(r)*pi,', s квадрата = ',sqr(a)); if (sqr(r)*pi) > (sqr(a)) then write('s круга больше, чем s квадрата') else if (sqr(r)*pi) < (sqr(a)) then write('s квадрата больше, чем s круга') else write('s круга = s квадрата'); end.
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Написать программу для решения следующей : вычислить сумму и количество положительных элементов последовательности.