dmitrievanata83538
?>

Написать программу на паскале. дана строка. верно ли, что второе слово начинается на ту же букву, которой заканчивается третье слово?

Информатика

Ответы

ninaandreeva3179
Var  s1,s2: string;   begin  write( 's1: ' );   readln(s1);   write( 's2: ' );   readln(s2);   if s1[ 1 ] = s2[ length(s2) ] then  write( 'da' ) else write( 'net' );   readln;   end. 
struev2003260
Например так program name_1; var name1, name2, name3, probel, dot: string; number: integer; begin name1 : = 'ivanov_ivan_xvanovic'; probel : = '_'; dot : = '.'; number : = pos(probel, name1); writeln(number); writeln(name1); {delete(name1, number+2, 60); } name2: =name1; name3: =name1; {вырезаем имя} delete(name1, number, 60); delete(name2, 1, number); {сформировали 1й инициал} delete(name2, 2, 60); delete(name3, 1, number); {формируем 2й инициал} number : = pos(probel, name3); delete(name3, 1, number); delete(name3, 2, 60); writeln('ваши инициалы: ',name1,' ', name2, dot, ' ', name3, dot); readln(); end. поясню, у меня с кирилицей иногда чудит, поэтому перешел на латиницу, ну и поменял букву в отчестве, чтоб быть уверенным, что вырезан именно 2й инициал, а не повторно 1й, они ж одинаковые были. при отладке пробел в строке заменял подчеркиванием, чтобы четко видеть, что режет программа.
MISAKOVNA49
Const   n=50; var   f: text;   s: string;   ss: array of string;   a: array[1..n] of string;   i,j: integer; begin   assign(f,'input.txt'); reset(f);   j: =0;   while not eof(f) do begin       readln(f,s);       ss: =s.split(' ');       for i: =0 to length(ss)-1 do           if length(ss[i])> 1 then               if rightstr(ss[i],2)='of' then               begin inc(j); a[j]: =ss[i] end;   end;   close(f);   for i: =1 to j do write(a[i],' ');   writeln end. тестовое решение: 123of asdfdsof dasof есть решение и покороче, но совсем не уровня начинающих: uses   system.text.regularexpressions; const   n=50; var   f: text;   s: string;   a: array[1..n] of string;   i,j: integer; begin   assign(f,'input.txt'); reset(f);   j: =0;   while not eof(f) do begin       readln(f,s);       foreach var m: match in regex.matches(s,'\b\s+of\b') do       begin inc(j); a[j]: =m.value end;   end;   close(f);   for i: =1 to j do write(a[i],' ');   writeln end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на паскале. дана строка. верно ли, что второе слово начинается на ту же букву, которой заканчивается третье слово?
Ваше имя (никнейм)*
Email*
Комментарий*