Program zananija_com; var x, y, z : integer; begin writeln('введите х'); readln(x); writeln('введите y'); readln(y); if (x < = y) then z : = x + y else z : = x - y; writeln('z = ', z); readln(); end.
leonidbaryshev19623
12.10.2021
Const n=10; var a: array[1..n]of integer; i: integer; begin for i: =1 to n do begin a[i]: =random(100)-50; write(a[i]: 4); if a[i]< 0 then a[i]: =0; end; writeln; for i: =1 to n do write(a[i]: 4); end.
kiruha0378
12.10.2021
Переводим число из двоичной системы в десятичную: 10(2) = 1 * 2^1 + 0 * 2^0 = 2 + 0 = 2 10(2) + 10(10) = 2(10) + 10(10) = 12(10) чтобы перевести число из системы счисления с основанием b, можно представить его в виде суммы: всё точно так же, как и в десятичной системе, только меняем 10 на основание системы счисления, например, другой способ – избежать большого количества возведений в степень и записать, например, так: берем первую цифру – умножаем на b, прибавляем вторую цифру – умножаем на b, прибавляем третью цифру – – умножаем на b, прибавляем последнюю цифру. чтобы перевести из десятичной в систему с основанием b, нужно по сути сделать в обратном порядке то, что написано выше: либо восстановить разложение в сумму, либо выписать остатки от деления на b в обратном порядке. например, переведем 27(4) в десятичную систему счисления: 27(4) = 1 * 16 + 2 * 4 + 3 * 1 = 1 * 4^2 + 2 * 4^1 + 3 * 4^0 = 123(4) 27 : 4 = 6 (ост. 3) 6 : 4 = 1 (ост. 2) 1 : 4 = 0 (ост. 1) выписываем в обратном порядке: 27(10) = 123(4)
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Даны числа: x, y. вычислите: z=x+y, если , и z=x-y в противном случае. написать программу в паскале.