Составить программу которая осуществляет преобразование единиц измерения величин значения мощности , измеренные в лошадиных силах , преобразуется в значения , измеренные в киловаттах (1.с.=0, 735 квт)
#include < iostream> using namespace std; int main() { float x; setlocale (lc_all, "russian"); cout < < "введите мощность в л.с.: "; cin > > x; cout < < "мощность в квт равна " < < x/ 1.35962 < < endl; system ("pause"); }
info8
11.09.2020
Японял и написал программу: uses crt; const n=25; type mas=array [1..n] of integer; var i, col: integer; a: mas; begin clrscr; randomize; col: =0; writeln(' massiv a: '); for i: =1 to n do begin a[i]: =10+random (90); write(a[i]: 3); if (a[i] mod 2=0) then col: =col+1; end; writeln; writeln; writeln(' col = ', col); readln; end.
valeron7hair7
11.09.2020
Вариант с процедурой delete var s: string; k: integer; begin write('введите слово: '); readln(s); write('какую по порядку букву удалить? '); read(k); delete(s,k,1); writeln('результат: ',s) end. вариант с функцией copy var s: string; k,n: integer; begin write('введите слово: '); readln(s); write('какую по порядку букву удалить? '); read(k); n: =length(s); s: =copy(s,1,k-1)+copy(s,k+1,n-k); writeln('результат: ',s) end. вариант с циклами var s,s1: string; k,i,n: integer; begin write('введите слово: '); readln(s); write('какую по порядку букву удалить? '); read(k); n: =length(s); s1: =''; for i: =1 to k-1 do s1: =s1+s[i]; for i: =k+1 to n do s1: =s1+s[i]; writeln('результат: ',s1) end. тестовое решение (одинаково для всех вариантов): введите слово: таракан какую по порядку букву удалить? 4 результат: таркан блок-схемы всех вариантов находятся во вложениях
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Составить программу которая осуществляет преобразование единиц измерения величин значения мощности , измеренные в лошадиных силах , преобразуется в значения , измеренные в киловаттах (1.с.=0, 735 квт)