kgrechin
?>

1. составьте программу , определяющую , является ли число х простым. число х введите с клавиатуры. число называется простым, если у него нет других делителей , кроме 1 и его самого.

Информатика

Ответы

vikabobkova2010
Var x: integer; begin  write('введите число: ');   read(x);   if x mod 2 = 0 then writeln('число простое')                                      else writeln('число не имеет общих делителей'); end.
Новиков1139
Надсистема-первая группа решений минимизации связана с использованием надсистемы. что такое надсистема? это то, что окружает систему; то, с чем она взаимодействует. для устройства – это окружающие его другие устройства, которые работают вместе. так, для плазменной панели в качестве надсистемы может выступать мультимедийный центр, который включает саму плазменную панель, dvd-плеер, игровую приставку, колонки, компьютер. подсистема- это набор объектов и подсистем, обеспечивающих некоторую функциональность, и взаимодействующих между собой в соответствии с их интерфейсами. интерфейс подсистемы представляет собой подмножество объединения интерфейсов всех объектов и подсистем, составляющих эту подсистему. в состав подсистемы может входить один, или более взаимозависимых объектов
КристинаАлександр
Var     mas: array [1..9] of integer;     summ, count: integer;     i: integer; begin      randomize;     summ : = 0;     count : = 1;     for i : = 1 to 9 do     begin         mas[i] : = random(-30, 30);         write(mas[i] : 4);         if mas[i] < 0 then summ : = summ + mas[i];         if mas[i] > 0 then count : = count * mas[i];     end;     writeln('');     writeln('сумма отрицательных элементов: ', summ);     writeln('произведение положительных элементов: ', count); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. составьте программу , определяющую , является ли число х простым. число х введите с клавиатуры. число называется простым, если у него нет других делителей , кроме 1 и его самого.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Alisa
vmnk38
Romanovna-yana
Gstoremsk62
Delyaginmikhail
Сухроб944
murin
olgavbaranova
zhandarmova
sttig
Dms161964937
juli19657
Державина
cleopatra1959
Grigorevna23