КузменковаЖигулин
?>

Дано число k (0 < k < 11) и матрица размера 4 x 10. найти сумму и произведение элементов k-го столбца данной матрицы. , нужно написать программу в паскале

Информатика

Ответы

ivstigres65
Var j,i,k,sum,proizv: integer; a: array [1..4,1..10] of integer; begin proizv: =1; randomize; writeln('матрица: '); for i: =1 to 4 do   for j: =1 to 10 do   a[i,j]: =random(21)-10; for i: =1 to 4 do   begin   for j: =1 to 10 do   write(a[i,j]: 5);     writeln;   writeln;   end; writeln('введите к: '); read(k); for i: =1 to 4 do   begin   sum: =sum+a[i,k];   proizv: =proizv*a[i,k];   end; writeln('cумма чисел ',k,'-ого столбца: ',sum); writeln('произведение чисел ',k,'-ого столбца: ',proizv);   end.
fotostock
Решение, что называется, "в лоб" (далеко, далеко, не самое лучшее): var s,k1,k5,k10,k50,k100,k500,k1000,k10000: integer; begin write('s = '); readln(s); k1: =0; k5: =0; k10: =0; k50: =0;   k100: =0; k500: =0; k1000: =0; k10000: =0; while s> =10000 do begin s: =s-10000; k10000: =k10000+1; end; while s> =1000 do begin s: =s-1000; k1000: =k1000+1; end; while s> =500 do begin s: =s-500; k500: =k500+1; end; while s> =100 do begin s: =s-100; k100: =k100+1; end; while s> =50 do begin s: =s-50; k50: =k50+1; end; while s> =10 do begin s: =s-10; k10: =k10+1; end; while s> =5 do begin s: =s-5; k5: =k5+1; end; while s> =1 do begin s: =s-1; k1: =k1+1; end; writeln('k10000=',k10000,' k1000=',k1000,' k500=',k500,' k100=',k100,' k50=',k50,' k10=',k10,' k5=',k5,' k1=',k1); writeln(' всего купюр = ',k1+k5+k10+k50+k100+k500+k1000+k10000); end. пример: s = 27879 k10000=2 k1000=7 k500=1 k100=3 k50=1 k10=2 k5=1 k1=4   всего купюр = 21
Irina Bakaev
Program p; var i: integer; quest: array [1..2] of string; ans: array [1..2] of string; answ: array [1..2] of string; begin quest[1]: ='20*2='; quest[2]: ='3*5='; ans[1]: ='40'; ans[2]: ='15'; for i: =1 to 2 do begin writeln ('вопрос номер ', i); writeln (quest[i]); write ('ваш ответ - '); readln (answ[i]); while answ[i]< > ans[i] do   begin   writeln ('ответ неверный, попробуйте снова');   readln(answ[i]);   end; writeln ('ответ верный'); writeln; end; writeln ('congrats'); end. пример: вопрос номер 1 20*2= ваш ответ - 40 ответ верный вопрос номер 2 3*5= ваш ответ - 10 ответ неверный, попробуйте снова 14 ответ неверный, попробуйте снова 15 ответ верный congrats

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дано число k (0 < k < 11) и матрица размера 4 x 10. найти сумму и произведение элементов k-го столбца данной матрицы. , нужно написать программу в паскале
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Irina1435
yliana
horina12
okunevo2010
drozd228758
yelena
uttgroup
Ruzalina_Svetlana1435
olgaprevisokova302
Gor Anatolevich
shangina1997507
abroskin2002
turoverova5
Владислав-Аветисян217
tenvalerij