Ferrigen
?>

Составьте программу вычисления произведения простых делителей натурального числа n.

Информатика

Ответы

Дил1779

program a1; var a: array[1..30] of integer;       amax,amin,i,imin,imax,n,s: integer; beginwriteln('введите n элементов массива'); readln(n); for i: =1 to n do a[i]: =random(30); writeln('введённый массив имеет вид'); for i: =1 to n do write(a[i], '  '); writeln; amax: =a[1]; imiax: =1; for i: =2 to n do  if a[i]> amax then begin  amax: =a[i]; imax: =i; end; amin: =a[1]; imin: =1; for i: =2 to n do  if a[i]< amin then begin  amin: =a[i]; imin: =i; end; writeln('полученный массив имеет вид'); s: =a[imin];

a[imin]: =a[imax];

a[imax]: =s; for i: =1 to n do  writeln(a[i],'  '); end.

aninepp

СХОДСТВА:

1. Оба адреса представляет собой адрес конкретного сетевого соединения (узла), идентифицирующий владельца этого узла. Каждый из миллионов компьютеров, обладающих доступом во Всемирную сеть, имеет собственный уникальный доменный и/или IP адрес.

2. Составные части доменного адреса называются его сегментами и образуют иерархическую систему. IP-адрес также состоит из сегментов, образующих иерархическую систему.

РАЗЛИЧИЯ:

1. Доменный адрес использует символьный поэтому представляет собой набор символов  — букв, цифр и некоторых знаков: слово или несколько слов, в том числе аббревиатур и сокращений, либо цифр без пробелов, идущих подряд и разделенных точками. Сегменты же в IP-адресе представляют собой наборы цифр — числа в диапазоне от 0 до 255 (в десятичной записи).

2. В отличие от доменного адреса, число сегментов в IP-адресе всегда равно четырем.

3. В IP-адресах иерархическая лестница спускается слева направо, а не справа налево, как в доменных адресах.

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу вычисления произведения простых делителей натурального числа n.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

tokarevmax
Petrovich
borodin
naromanova
rusart3
filimon131262
Исмагилова_Саният
manu95957
taa19707470
druzjkinaas22
Zhanibekrva Kandaurova
kategar
tumanowivan2015509
nkochladze
tarrin-ka