Составьте программу, которая формируют массив из шестнадцати случайных целых чисел от -20 до 20 и: а) находит элементы с нулевыми значениями; б) находит индексы четных элементов;
Var i: integer; a: array [1..16] of integer; begin randomize; writeln('массив: '); for i : = 1 to 16 do begin a[i] : = random(41) - 20; write(a[i]: 5); end; writeln; writeln('нулевые элементы: '); for i : = 1 to 16 do if a[i] = 0 then write(i: 5); writeln; writeln('четные элементы: '); for i : = 1 to 16 do if a[i] mod 2 = 0 then write(i: 5); end.
maestro6838
08.08.2021
Белов георгий, суворов дмитрий, серёгин евгений, лоскутов юлий, серегина наташа, суворова евгения. решение: у 2-ой девушки имя как у серегина только 2 имени могут быть как мужским, так и женским - юлий и евгений серегин не может быть юлием, т.к. играет не в теннис, а в шахматы, значит серегин - евгений, а 2-я девушка - евгения. наташа была замужем за евгением, значит можно предположить, что она носит его фамилию => наташа - серегина. суворов не евгений (уже занято), не юлий, т.к. играет в шахматы, а не в теннис, и не георгий, т.к. из москвы, а не из саратова => суворов - дмитрий. => 2-я девушка евгения - суворова, т.к. ее фамилия, такая же, как у дмитрия. лоскутов из ярославля, значит он не может быть георгием => лоскутов - юлий. остается одна фамилия белов и одно имя георгий => белов - георгий
oalexandrova75
08.08.2021
Подавляющему большинству пользователей персональных компьютеров имя карла дугласа энгельбарта вряд ли о чем-то говорит. но это никак не мешает более чем 1 млрд человек каждый день использовать его творения. при этом одним из самых популярных и востребованных на сегодняшний день является компьютерная мышка.родился этот уникальный человек в 1925 году, 30 января недалеко от портланда, штат орегое, в семье обычного фермера-трудяги. ну а дальше рос он как обыкновенный мальчик: ходил в школу, закончив ее, поступил в местное высшее учебное заведение. уже тогда он хотел стать электриком. официальный год создания компьютерной мыши – 1964в 1964 году команде доктора дугласа энгельбарта было поручено создать arpanet network information center, предшественник сегодняшнего интернета. ну и что же, как побочный эффект этого проекта на свет появился первый манипулятор, который получил название компьютерная мышь.это уникальное изобретение, без которого сегодня тормозится любая деятельность на компьютере, на самом деле разработали случайно. существующие тогда манипуляторы (клавиатура, джойстики и световые перья) тормозили процессы оконной среды, поэтому дуглас быстро придумал дополнение, которое должно было облегчить текущие процессы. а это приспособление потом оказалось гениальным изобретением! компьютерной мышки.в одних компьютерных легендах рассказывается, что компьютерную мышку создали в технической лаборатории xerox, другие говорят – что она была создана по просьбекомпании apple. компьютерная мышь на самом деле является индикатором позиций y и x, она же самый настоящий компьютерный манипулятор. стоит отметить, что манипулятор типа «мышь» появился еще в 1964 г. ее изобретателем стал дуглас карл энгельбарт, ученый из стэнфордского.первоначально не было на мышь «госзаказа» – она появилась как побочный продукт при разработке энгельбартом on-line system операционной системы (nls). работая над nls, была предложена концепция «оконного» интерфейса, и только тогда компьютерная мышка была создана в роли одного их возможных манипуляторов для дальнейшей работы с окнами. изначально, идея этого манипулятора появилась еще в 1963 году, а уже в 1964 году был сделан первый рабочий прототип.
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Составьте программу, которая формируют массив из шестнадцати случайных целых чисел от -20 до 20 и: а) находит элементы с нулевыми значениями; б) находит индексы четных элементов;