monenko
?>

3. написать программу, определяющую, лежит ли точка с указанными координатами а (x, y) на окружности радиуса r с центром в начале координат (может лежать на окружности, внутри окружности, вне окружности) ps: pascal(не турбо) всем буду !

Информатика

Ответы

sergeev-alp5
Var x,y, r: iinteger; begin write('введите координату x: '); readln(x); write('введите координату y: '); readln(y); write('введите длину радиуса r: '); readln®; if (sqr(x)+sqr(y))=r then writeln('точка лежит на окружности! ') else writeln('точка не лежит на окружности! '); end.
sport2293032
Const   nn=30;   mm=30; var   m,n,i,j: integer;   s: longint;   a: array[1..mm,1..nn] of integer; begin   randomize;   read(m,n);   s: =0;   for i: =1 to m do begin       for j: =1 to n do begin           a[i,j]: =random(101)-50;           write(a[i,j]: 4);           s: =a[i,j]*sqr(a[i,j])           end;       writeln       end;   writeln('сумма кубов равна ',s)   end. пример 4 5   21 -47 -14 -24 -40   34 -49  45 -21 -49   -34 -21  25  41 -46   -44  49 -10    2  14 сумма кубов равна 2744
aivanova
Короче примерно набросал #include < stdio.h> #include < conio.h> #include < time.h> #include < stdlib.h> #include < math.h> #define n 5 #define m 10 int main(){ int a[n][m],i,j,sum=0; srand((unsigned)time(null)); for (i=0; i< n; i++){     for(j=0; j< m; j++){       a[i][j]=rand()%10+1;   } };   for (i=0; i< n; i++){   for(j=0; j< m; j++){     sum=pow(a[i][j],3)+sum;   } };   printf("%d",sum);   getch (); return 0; }

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

3. написать программу, определяющую, лежит ли точка с указанными координатами а (x, y) на окружности радиуса r с центром в начале координат (может лежать на окружности, внутри окружности, вне окружности) ps: pascal(не турбо) всем буду !
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Mikhail_Magomed635
kogakinoa
ghjcnjtyjn64
chulki-kupit
Yevgenevich_Chipura-Nikolaeva
marychev55
stairov536
ska67mto3983
andrewa
nelli-bi6
iracaenko153
Катерина Телюкин925
anna-ditman
tarasovs
shuttse