galinab1111326
?>

Каждая бактерия делится на две в течение одной минуты. в начальный момент времени имеется одна бактерия. составьте программу, которая рассчитывает количество бактерий на заданное пользователем с клавиатуры целое значение момента времени 15 минут. мне через паскаль нужно и еще что бы через операторы white и do. нужно заранее.

Информатика

Ответы

Антонович937
Var a,b,c: integer; begin a: =1; b: =0; write('введите кол-во минут: '); readln(c); while (b< > c) do begin a: =a*2; b: =b+1; end; writeln(a); end.
ilds88
1) для моделирования своих проектов 2) для хранения информации о пациентах 3) для создания презентаций к урокам, для хранения информации об учениках 4) для связи с коллегами через интернет 5) для хранения и учета информации о бюджете 6) ком/спозитор? ? 7) для хранения информации о встречах, делах начальника 8) для быстрого написания текста, хранения его 9) для создания картин на нем, для поиска вдохновения 10) для создания новых моделей, поиска через интернет чего-то нового и хранения это на пк
vakhitov100961
Const     n = 13; var     a: array[1..n] of integer;     i,k,b: integer; begin randomize; k: =0; write('исходный массив: '); for i: = 1 to n do       begin       a[i]: =random(1001)+1000;       write(' ',a[i]);       b: =a[i];       while b div 100 > 0 do             b: =b div 10;       if (b mod 10) mod 2 = 0 then k: =k+1;       end; writeln; writeln('искомое количество: ',k); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Каждая бактерия делится на две в течение одной минуты. в начальный момент времени имеется одна бактерия. составьте программу, которая рассчитывает количество бактерий на заданное пользователем с клавиатуры целое значение момента времени 15 минут. мне через паскаль нужно и еще что бы через операторы white и do. нужно заранее.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

tushina2020
ivnivas2008
Anatolevich667
ЕвгенияСергеевна
tershova
Татьяна_Вологжин
gorodof4292
konss2
sveta740450
Maksim Lokhov
Меладзе_Владимир1695
Serdechnaya636
ElenaSkvortsova2
БашуроваОльга369
zeltos384