АнтонАртем
?>

1составьте программу , вычисляющую сумму кубов первых n натуральных чисел 2туристы в 1-ый день прошли 7км.в каждый следующий день они проходили на 1.5 км > .составь программу , вычисляющую сколько километров они пройдут за n дней. ,

Информатика

Ответы

Елена
1const n = 100; var a: array[1..n] of word; i, m: byte; sum: word; begin write('kol-vo chisel: '); readln(m); sum: =0; for i: =1 to m do     begin     a[i] : = i;     write(a[i]: 4);     sum: =sum + sqr(a[i])*a[i];     end;     writeln;     writeln('sum = ', sum: 4);   readln; end. 2 constn = 100; vara: array[1..n] of word; i, dn: byte; km: real; beginwrite('kol-vo dney: '); readln(dn); km: =7; for i: =2 to dn do    km: =km+(km+1.5); writeln; writeln('turisty proshli ', km: 4: 1, ' km'); readln; end.
Можарова14

ты т у п о й. д е б и л мен саған не керек едым қазақ халқының дәстүрлі емес інім нури да бар бірақ ол кезде ол не дейді қазақ тілінде тест на әк тастан жасалған дән мен саған не болды деп көрсетеді және бұл да бар екен не было қазақ тілінде неше әріп не зоч да көп болуы тиіс ал запрос да көп болды ал аккаунт мен бжб да бір басқа да көптеген қазақ халқының саны шамамен екі жүз айлық есептік көрсеткіш мөлшерінде айыппұл салуға не екі жүз он бес сыры да осында қазақ тілінде неше септік көмектес септігі тиеді деп аталады ал аккаунт мен бжб матем мен саған не болған жағдайда оны

bmargarita

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

31

program pr;

 

var

 n, i, k, m: integer;

 

begin

 k := 0;

 writeln('Введите количество чисел последовательности');

 readln(n);

 if n <= 1000 then  

 begin

   for i := 1 to n do

   begin

     writeln('Введите ', i, ' число:');

     readln(m);

     if abs(m) <= 30000 then

     begin

       if (m mod 3 = 0) and (m mod 10 = 2) then

         inc(k);

     end

     else  

     begin

       writeln('Число по модулю не должно превышать 30000');

       exit;  

     end;

   end;

   writeln('Количество элементов последовательности кратных 3 и оканчивающихся на 2: ', k);

 end

 else  

   writeln('Количество не должно превышать 1000');

end.

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1составьте программу , вычисляющую сумму кубов первых n натуральных чисел 2туристы в 1-ый день прошли 7км.в каждый следующий день они проходили на 1.5 км > .составь программу , вычисляющую сколько километров они пройдут за n дней. ,
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Guru-tailor
gelena03
dilanarthur27
Neveselova
ski89439
bespalovaannaanna
adminaa
turovvlad
mirsanm26249
petrakovao
fruktovahere
Потапова 79275136869323
leeteukism
dima0218687
ss2911