Самохвалова-Геннадьевна
?>

Найдите наибольший общий делитель двух чисел. или для цикла (пока), или для цикла (до) в паскале.

Информатика

Ответы

spz03
Var a, b, answer: integer; function gcd(m, n: integer): integer;       var modulo: integer;     begin              modulo : = m mod n;         if modulo = 0 then            gcd : = n                else            gcd : = gcd (n, modulo)    end; begin              write('введите 2 числа: ');     readln(a, b);     answer : = gcd(a, b);     writeln('наибольший общий делитель: ', answer); end.
aistenok-28

у сучасному світі виникла велика кількість нових явищ, які мають на людину великий вплив. одним з таких є інтернет. інтернет, напевно, став займати дуже важливе місце в житті кожної людини. він стосується всього, що має відношення до будь-якої інформації або обміну нею. в інтернеті сьогодні сидять усі – починаючи від школярів і закінчуючи людьми похилого віку, він корисний для всіх. однак далеко не факт, що інтернет дає одну лише користь. до всіх явищ, в тому числі і самих корисних, слід ставитися з належною часткою критики, тому я пропоную розглянути ризики, пов’язані з впливом інтернету на людину.

по-перше, є чисто фізіологічний ризик. інтернет вимагає уваги, а увагу далеко не так просто приділити, якщо ти знаходишся в русі. отже, інтернет змушує тебе сидіти на одному місці і не рухатися. а це загрожує виникненням проблем зі здоров’ям. тому людина не повинна поринати в інтернет з головою. потрібно залишати місце для активної спортивної діяльності, спілкування з іншими, будь-якого руху. в іншому випадку можна отримати серйозні проблеми і пошкодувати про те, що проводив так багато часу за комп’ютером.

marinakmaa86
Pascalabc.net 3.4.2, сборка 1884 от 24.11.2018 внимание! если программа не работает, обновите версию!

begin

  var p : = readarrinteger('вводите: ', 20);

  var a : = readinteger('a =');

  p.indexesof(t -> t > a).println; // индексы от нуля!

  p.indexesof(t -> t > a).select(t -> t + 1).println; // номера от 1

end.

пример

вводите: -16 30 -24 30 -14 -11 -16 -2 -14 7 -23 9 9 11 -10 -5 25 30 -22 -6

a = 5

1 3 9 11 12 13 16 17

2 4 10 12 13 14 17 18

выберите, что вам нужно и удалите лишний вывод

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Найдите наибольший общий делитель двух чисел. или для цикла (пока), или для цикла (до) в паскале.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Chernaya
kgrechin
kononova_Pavel689
Alena824
alfakurs
Алексеевич620
bhg50
Маринова
Герасименко
Anatolevich
Yuliya mikhail
veronica1344
Алёна Геннадьевна98
ZharikovZalina
Gennadevna_Baidalina131