Oslopova
?>

Составить программу которая будет находить все простые числа из промежутка от 4 до 60. использовать рекурсивную функцию. паскаль

Информатика

Ответы

jenko87

var

nr , v1 , va , na : real;

begin

  writeln('сколько рыбок? ');

  readln(nr);

  while(nr < = 0) do

      begin

        writeln('некорректное число');

        writeln('сколько рыбок? ');

        readln(nr);

      end;

     

  writeln('сколько литров на одну рыбку? ');

  readln(v1);

    while(v1 < = 0) do

      begin

        writeln('некорректное число');

        writeln('сколько литров на одну рыбку? ');

        readln(v1);

      end;

     

  writeln('требуется воды = ', v1*nr, ' л');

  writeln('сколько аквариумов можно разместить? ');

  readln(na);

    while(na < = 0) do

      begin

        writeln('некорректное число');

        writeln('сколько аквариумов можно разместить? ');

        readln(na);

      end;

     

  writeln('какой объем у аквариумов? ');

  readln(va);

    while(va < = 0) do

      begin

        writeln('некорректное число');

        writeln('какой объем у аквариумов? ');

        readln(va);

      end;

     

  if (v1*nr < = va*na) and (na < = nr) then  

    begin

      writeln('минимальный объем (в литрах) в аквариуме = ', va);

    end

  else

    begin

      writeln('no');

    end;

   

end.

janepustu
Вверх — переместить робота на одну клетку вверх вниз — переместить робота на одну клетку вниз влево — переместить робота на одну клетку влево вправо — переместить робота на одну клетку вправо закрасить — закрасить текущую клетку (клетку в которой находится робот). так же есть циклы если условие то серия 1 иначе серия 2 все выбор при условие 1 : серия 1 при условие 2 : серия 2 … при условие n : серия n иначе серия n+1 и условия слева стена справа стена снизу стена сверху стена клетка закрашена слева свободно справа свободно снизу свободно сверху свободно клетка чистая

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу которая будет находить все простые числа из промежутка от 4 до 60. использовать рекурсивную функцию. паскаль
Ваше имя (никнейм)*
Email*
Комментарий*