ver2bit
?>

Три точки а(х₁; у₁), в(х₂; у₂), с(х₃; у₃) своими координатами.написать программу, которая определяет, какая из этих точек ближе к началу координат.

Информатика

Ответы

vikgor45
Var x1,x2,x3,y1,y2,y3,r1,r1,r3: real; begin writeln ('введите координаты a'); readln (x1,y1); writeln ('введите координаты b'); readln (x2,y2); writeln ('введите координаты c'); readln (x3,y3); r1: =sqrt(x1*x1+y1*y1); r2: =sqrt(x2*x2+y2*y2); r3: =sqrt(x3*x3+y3*y3); if (r1< =r2) and (r1< =r3) writeln('точка а ближе'); if (r2< =r1) and (r2< =r3) writeln('точка b ближе'); if (r3< =r1) and (r3< =r2) writeln('точка c ближе'); readln; end
tata-novik

Для чтения/записи файлов в C# можно использовать несколько подходов в зависимости от задачи. Например, если нужно вывести весь текст из файла в консоль - можно использовать File.ReadAllText(). Если же нужно форматировать каждую строку файла или, например, необходимо считывать текст файла по одному символу - можно использовать StreamReader. Разумеется, считывать с файла можно не только сплошной текст. Это могут быть байты, отдельные строки; опять же в зависимости от задачи. Аналогичная ситуация с записью в файл. Для записи используем File.WriteAllBytes() или StreamWriter. Классы File, StreamReader, StreamWriter и др. находятся в пространстве имен System.IO. Обязательно напишите строку кода: using System.IO; или обращайтесь к классу так: System.IO.File.ReadAllLines(); Также хочу сразу предотвратить возможную ошибку: если вы открываете файл для записи/чтения, не забудьте освободить ресурсы. Иначе файл так и останется открытым, и если к нему еще раз обратиться, то будет ошибка.  Для этого закрывайте файл или освобождайте ресурсы вручную: File.Create().Close(); или reader.Dispose(); Но есть возможность делать это автоматически. Для этого нужно использовать using как в моем коде.

Для наглядности привожу пример программы. Задача: считать из файла имена людей и записать в другой файл отсортированный список. Затем взять сообщение из файла, закодировать, поместить закодированное сообщение в файл. Получить из файла закодированное сообщение, расшифровать и вывести в консоль. Для решения использовал основные приемы для чтения/записи файла. Также сделал краткие комментарии. Надеюсь, всё было понятно. Поскольку в ответе код скорее всего отформатируется криво, прикрепил фотографию с "красивым" кодом, а также фотографию входных и выходных файлов.

Код:

using System;

using System.IO;

using System.Text;

using System.Collections.Generic;

namespace ConsoleApp1

{

   internal class Program

   {

       private static void Main(string[] args)

       {

           //Путь к входным и выходным файлам.

           const string inputPath1 = @"D:\ProgramsTester\Input1.txt";

           const string inputPath2 = @"D:\ProgramsTester\Input2.txt";

           const string outputPath1 = @"D:\ProgramsTester\Output1.txt";

           const string outputPath2 = @"D:\ProgramsTester\Output2.txt";

           //Список.

           List<string> items = new List<string>();

           //Использует StreamReader, а затем высвобождает ресурсы.

           using (StreamReader reader = new StreamReader(inputPath1))

           {

               //Читает весь файл.

               while (!reader.EndOfStream)

               {

                   items.Add(reader.ReadLine());

               }

           }

           //Сортировка массива.

           items.Sort();

           //Использует StreamWriter, а затем высвобождает ресурсы.

           using (StreamWriter writer = new StreamWriter(outputPath1))

           {

               //Записывает отсортированный список в файл.

               for (int i = 0; i < items.Count; i++)

               {

                   writer.WriteLine(items[i]);

               }

           }

           //Байты из файла, хранящего сообщение, записываются в массив байт.

           byte[] fileBytes = File.ReadAllBytes(inputPath2);

           //Запись закодированного сообщения в файл.

           File.WriteAllText(outputPath2, Convert.ToBase64String(fileBytes));

           //Вывод декодированного сообщения, полученного из файла.

           Console.WriteLine("Decoded text: " + Encoding.Default.GetString(Convert.FromBase64String(File.ReadAllText(outputPath2))));

           _ = Console.ReadKey();

       }

   }

}


Считывание/запись файла в С#. Пример с описанием​
Считывание/запись файла в С#. Пример с описанием​
Yurevna

#include <iostream>

using std::cin;

using std::cout;

int main(int argc, char const* argv[]) {

int n;

cout << "Enter size of array:\n";

cin >> n;

int *mas1 = new int[n];

int *mas2 = new int[n];

cout << "Enter elements of array:\n";

for (register int i = 0; i < n; i++) {

 cin >> mas1[i];

}

int counter = 0;

for (register int i = 0; i < n; i++) {

 if (mas1[i] < 0) {

  mas2[counter] = mas1[i];

  counter++;

 }

}

for (register int i = 0; i < n; i++) {

 if (mas1[i] == 0) {

  mas2[counter] = mas1[i];

  counter++;

 }

}

for (register int i = 0; i < n; i++) {

 if (mas1[i] > 0) {

  mas2[counter] = mas1[i];

  counter++;

 }

}

for (register int i = 0; i < n; i++) {

 cout << mas2[i] << std::endl;

}

return 0;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Три точки а(х₁; у₁), в(х₂; у₂), с(х₃; у₃) своими координатами.написать программу, которая определяет, какая из этих точек ближе к началу координат.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Мунировна
Юлия1972
vipteatr
AnzhelikaSlabii1705
mikhisakov2017
ikuvila5484
ЕкатеринаРустам
Маргарита1091
magazin3000
dmitrijku
Меладзе_Владимир1695
Georgievna
samuilik-v
Zakharov Lilit
Yanusik24