egoryuzbashev
?>

1. составьте программу, которая выводит на экран таблицу перевода a, a+1, a+2, … b бит в килобайты. границы a и b вводятся с клавиатуры. протокол: введите границы: 5000 5004 5000 бит = 0.61035 кб 5001 бит = 0.61047 кб 5002 бит = 0.61060 кб 5003 бит = 0.61072 кб 5004 бит = 0.61084 кб 2. составить программу для нахождения суммы по следующей формуле: где m вводится с клавиатуры. 3. составить программу для решения следующей : ежемесячная стипендия студента составляет a рублей в месяц, а расходы на проживание превышают стипендию и составляют b рублей в месяц. рост цен ежемесячно увеличивает расходы на 3%. разработать схему алгоритма для расчёта необходимой суммы денег, которую надо единовременно попросить у родителей, чтобы можно было прожить учебный год (10 месяцев), используя только эти деньги и стипендию.

Информатика

Ответы

rayon14
1) var       a, b, i: longint; begin       read(a, b);       for i : = a to b do               writeln(i: 10, ' бит = ', i / 8 / 1024: 10: 5, ' кб'); end. 3) var       a, b, s: real;       i: integer; begin       read(a, b);       for i : = 1 to 10 do       begin               s : = s + b;               b : = b * 1.03;       end;       writeln(s - 10 * a); end.
rynaodal
1) //pascalabc.net версия 3.2, сборка 1389 //если программа не запускается, то обновите версию begin       var a : = arrrandominteger(20, 100, 200);       println(a);       var k : = a.count(x -> x mod 10 = 5);       writeln((k = 0) ? 'таких чисел нет' : k.; end. 2) //pascalabc.net версия 3.2, сборка 1389 //если программа не запускается, то обновите версию begin       var a : = arrrandominteger(40, -100, 100);       println(a);       var max : = a.count(x -> x mod 3 = 0);       if max < > 0 then               max : = a.where(x -> x mod 3 = 0).max;       writeln((max = 0) ? 'таких чисел нет' : max.; end.
demon8608
#код на ruby 2.2.3p173 def zadanie(line, time)       line = line.gsub(/[^md]/, "")       time.times {             k = 0             while k < line.size - 1 do                   if  line[k..k + 1] == "dm"                         line[k], line[k + 1] = line[k + 1], line[k]                         k+=1                   end                   k+=1                   p [k,line]             end       }       return line end # # примеры применения p zadanie("mdddmmdmdddmmmmmmddm", 10) ответ для примера "mmmmmmmmdmdmdmdddddd"

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. составьте программу, которая выводит на экран таблицу перевода a, a+1, a+2, … b бит в килобайты. границы a и b вводятся с клавиатуры. протокол: введите границы: 5000 5004 5000 бит = 0.61035 кб 5001 бит = 0.61047 кб 5002 бит = 0.61060 кб 5003 бит = 0.61072 кб 5004 бит = 0.61084 кб 2. составить программу для нахождения суммы по следующей формуле: где m вводится с клавиатуры. 3. составить программу для решения следующей : ежемесячная стипендия студента составляет a рублей в месяц, а расходы на проживание превышают стипендию и составляют b рублей в месяц. рост цен ежемесячно увеличивает расходы на 3%. разработать схему алгоритма для расчёта необходимой суммы денег, которую надо единовременно попросить у родителей, чтобы можно было прожить учебный год (10 месяцев), используя только эти деньги и стипендию.
Ваше имя (никнейм)*
Email*
Комментарий*