Лилит_Шутова
?>

30 ! составьте программу , которая формирует массив , содержащий 8 случайных целых чисел, принадлежащих промежутку [0; 5] , и преобразует элементы массива по следующему правилу: чётное число умножает на 5 , а от нечётного отнимает 2.

Информатика

Ответы

Алена
Uses crt; var a: array[1..8] of integer;     x: integer; begin       randomize;       for x: =1 to 8 do       begin           a[x]: =random(6);           writeln('a[',x,']: ',a[x]);       end;       writeln;       for x: =1 to 8 do       begin           if a[x] mod 2=0 then a[x]: =a[x]*5               else a[x]: =a[x]-2;           writeln('a[',x,']: ',a[x]);       end; end.
salahovta
Var a: array[1..8] of integer; i: integer; begin randomize; for i: =1 to 8 do begin  a[i]: =random(6);       if a[i] mod 2 = 0 then a[i]: =a[i]*5   else a[i]: =a[i]-2;   write(a[i],' ');   end; end.надеюсь на "лучший ответ"
okabankova7

Восстановим порядок выполнения команд:

1) прибавь 4 — 48 + 4 = 52

2) раздели на b — 52 / b = ...

3) прибавь 4 — ...

4) прибавь 4 — ...

5) прибавь 4 — 12 + 4 = 16

Рассмотрим детальней, заменив неизвестные на буквы:

1) прибавь 4 — 48 + 4 = 52

2) раздели на b — 52 / b = x

3) прибавь 4 — x + 4 = y

4) прибавь 4 — y + 4 = 12

5) прибавь 4 — 12 + 4 = 16

Теперь выписываем выражения с неизвестными и методом подстановки создаем одно большое уравнение:

52 / b = x

x + 4 = y

y + 4 = 12

52 / b + 4 + 4 = 12

52 / b = 4

b = 52 / 4 = 13

Неизвестное число b равно 13.

Проверяем:

1) прибавь 4 — 48 + 4 = 52

2) раздели на b — 52 / 13 = 4

3) прибавь 4 — 4 + 4 = 8

4) прибавь 4 — 8 + 4 = 12

5) прибавь 4 — 12 + 4 = 16

Все верно

ответ: 13

alekseymedvedev1981
Var  a,b,c,n: integer; begin for a: =1 to 7 do   for b: =a+1 to 8 do     for c: =b+1 to 9 do       begin       n: =a*100+b*10+c;       write(n: 4)       end; end.var    i,j,n: integer;     a: array[1..4,1..5]of real; beginfor i: =1 to 4 do  begin  for j: =1 to 5 do    begin    a[i,j]: =random*2-1;     write(a[i,j]: 20: 15);     if a[i,j]> =0 then n: =n+1;     end;   writeln;   end; writeln('количество неотрицательных: ',n); end.var    i,j,sum: integer;     a: array[1..3,1..4]of integer; beginfor i: =1 to 3 do  for j: =1 to 4 do    readln(a[i,j]); writeln('массив: '); for i: =1 to 3 do  begin  for j: =1 to 4 do    begin    sum: =sum+a[i,j];     write(a[i,j]: 4);     end;   writeln('sum=': 8,sum);   sum: =0;   end; end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

30 ! составьте программу , которая формирует массив , содержащий 8 случайных целых чисел, принадлежащих промежутку [0; 5] , и преобразует элементы массива по следующему правилу: чётное число умножает на 5 , а от нечётного отнимает 2.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Irinalobanowa
Shtorm-Shoe
mariashapar
Галина-Юлия1292
seleznev1980
bulenbeiser
Бегун-Марина
rkorneev19061
dmitrievanata83538
vapebroshop
oksanashabanovadc3197
margarita25061961
Pilotmi247074
Голосова-Лобанов1555
Яковчук1911