docvet4
?>

Найдите среднее значение из трех чисел x , y , k. составить программу pascal и блок схему

Информатика

Ответы

ViktorovnaKraeva634
Program gt; var x,t,k,s: real; begin read(x,y,k); s: =x+y+k; s: =s/3; writeln(s); end.
printdecor
//pascalabc.net 3.0 сборка 1139 (10.01.2016) begin       var a : = arrrandom(10, 1, 100);       a.println;       if not a.any(x -> x mod 7 = 0) then begin               writeln('нет элемента, что делится на 7');               halt();       end;             var n7 : = 0;       for var i : = low(a) to high(a) do               if a[i] mod 7 = 0 then begin                       n7 : = i;                       break;               end;       var t : = a[(low(a) + high(a)) div 2];       a[(low(a) + high(a)) div 2] : = a[n7];       a[n7] : = t;             a.println; end.
a-lossev111
// pascalabc.net 3.1, сборка 1179 от 29.02.2016 const   n=15; var   a: array[1..n] of integer;   i,k,t: integer; begin   randomize;   k: =0;   for i: =1 to n do begin       a[i]: =random(90)+10;       if k=0 then           if a[i] mod 7 = 0 then k: =i;       write(a[i],' ')       end;   writeln;   if k> 0 then begin       if odd(n) then i: =n div 2+1       else i: =n div 2;       t: =a[k]; a[k]: =a[i]; a[i]: =t;       for i: =1 to n do write(a[i],' ');       writeln       end   else writeln('нет элементов, кратных 7') end. тестовое решение: 25 25 47 22 51 63 92 11 38 32 87 54 11 16 18 25 25 47 22 51 11 92 63 38 32 87 54 11 16 18

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Найдите среднее значение из трех чисел x , y , k. составить программу pascal и блок схему
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

olgakuz00261
Филипп1054
Дмитрий_Владимирович1162
avtalux527
BogdanR106203
rmitin
sotrudnik3
zsv073625
antoska391
nord248
info40
AleksandrovnaIgor
Kisuha8465
guzelda19904850
kzhgutova