Nikolaevich_Vladimirovich1509
?>

Написать программу находящую количество цифр вводимого неотрицательного положительного числа

Информатика

Ответы

mmihail146
Var   a, c : integer; begin   readln (a);   c : = 0;   if (a = 0) then c : = 1   else     while a < > 0 do     begin       c : = c + 1;       a : = a div 10;       end;   writeln (c); end.
YekaterinaAbinskov

Вот точно таких же вопросов на этом сайте несколько сотен, если не тысяч

Учитываем, сколько занимает памяти каждый символ. Для этого надо знать кодировку. Если кодировка не указана, то по умолчанию считаем, что один символ занимаем один байт - восемь бит.

Перемножаем все три числа 100 страниц * 35 строк * 50 символов в строке = 175000 символов в книге, или 175000 байт в нашем случае.

Каждый байт содержит 8 бит, так что 175000 байт * 8 бит в байте = 1400000 бит

Кб содержит 1024 байта, 175000 байт / 1024 ≈ 170.9 КБайт

Мб содержит 1024 Кбайта, 170.9 Кбайт / 1024 ≈ 0.167 МБайт

Vs1377

Символ @, который мы используем в электронном адресе, изобрел создатель электронной почты Рэй Томлинсон. Впрочем, его происхождение уходит вглубь веков. Корреспондент BBC Future исследует его историю, а также необычные и поэтические названия @ в разных языках мира.

В нем прекрасно и подробно рассказано, как в 1971 году 29-летний компьютерный инженер Рэй Томлинсон изобрел всемирную эмблему, когда остановил свой выбор на довольно непонятном значке @, который должен был стать центральным символом его новаторской системы передачи электронных сообщений.

я пыталась)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу находящую количество цифр вводимого неотрицательного положительного числа
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kulikovtsud
Arzieva Abdulmanov1438
ГегамБукреев830
Что это такое? (FF80::123:1234:ABCD:EF12/48)
katrinasvr
Lavka2017
chernova1exei862
Михеев557
Лежачёва355
NarekAlekseevich779
Itina321t
vikanikita
ribanina
Ingakazakova
pavpe4198
osipov1984osipov