Vyacheslav_Nikolaevna
?>

Прошу ! нужно написать программу для решения следующей : вычислить количество элементов числовой последовательности а, удовлетворяющих условию -0, 2< =sin ai < =0, 5, i=1, n

Информатика

Ответы

arammejlumyan
#include < iostream> using namespace std; void main() {int n,k=0; float b=0; cout< < "vvedite n="; cin> > n; cout< < endl; float* f = new float [n]; for(int i=1; i< =n; i++) { cout< < "a["< < i< < "] = "; cin> > f[i]; } for(int i=1; i< =n; i++) {     b=f[i]; if(-0.2< =sin(b)< =0.5) {            k++;   cout< < "znachenie sinysa = "< < i< < "el-ta "< < sin(f[i])< < endl; } b=0; } cout< < " kol-vo ravno="< < k< < endl; system("pause"); }
brovkinay
Var a,b,c,r,s,p: real; begin   write('длины сторон треугольника a,b,c через пробел: ');   readln(a,b,c);   write('радиус круга r: ');   readln(r);   p: =(a+b+c)/2;   s: =sqrt(p*(p-a)*(p-b)*(p-c));   if r> =(a*b*c)/(4*s) then writeln('можно поместить')   else writeln('нельзя поместить'); end.длины сторон треугольника a,b,c через пробел: 3 4 5 радиус круга r: 2.49 нельзя поместитьдлины сторон треугольника a,b,c через пробел: 3 4 5 радиус круга r: 2.5 можно поместить
Aleksandrovich_Mitoyan1138
// pascalabc.net 3.2, сборка 1374 от 10.01.2017 // внимание! если программа не работает, обновите версию! begin   writeln('*** исходная матрица ***');   var a: =matrrandom(4,8,-99,99);   a.println(4); writeln(4*a.colcount*'-');   var sa: =a.rows.selectmany(x-> x);   writeln('положительные элементы: ');   sa.where(x-> x> 0).println;   write('максимальный по модулю элемент: ',sa.max(x-> abs(; end. пример *** исходная матрица ***   80    9  -8  32  37  75  43 -72   71 -79  94 -20 -64 -37 -98  53   19  84 -63  -4  17    5  38 -86   -32  56  87 -43  28 -40 -35  24 положительные элементы: 80 9 32 37 75 43 71 94 53 19 84 17 5 38 56 87 28 24 максимальный по модулю элемент: 98

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Прошу ! нужно написать программу для решения следующей : вычислить количество элементов числовой последовательности а, удовлетворяющих условию -0, 2< =sin ai < =0, 5, i=1, n
Ваше имя (никнейм)*
Email*
Комментарий*