Abdulganieva1367
?>

Напишите программу, которая, запросив число n, печатала бы числа от 1до n в обратном порядке.

Информатика

Ответы

Karina-evgenevna1899
Program n1; uses crt; var n,i: integer; begin writeln('введите число n'); readln(n); for i: =n downto 1 do writeln(i); end.
oserdyuk41

program pr;

label cyc;

const

sizex = 4; // количество ячеек в каждой строке

sizey = 4; // количество строк

var

matrix: array[1..sizey, 1..sizex] of integer;

i,k: integer;

begin

writeln('чтение элементов массива');

for i: =1 to sizey do for k: =1 to sizex do readln(matrix[i,k]);

writeln('исходный массив: ');

for i: =1 to sizey do begin

for k: =1 to sizex do begin

  write(matrix[i,k]);

end;

writeln('');

end;

writeln('подходящие строки: ');

for i: =1 to sizey do begin

for k: =2 to sizex do begin

  if matrix[i,k]> =matrix[i,k-1] then goto cyc;

end;

writeln(i);

cyc:

continue;

end;

end.

officem695
S- заданная символьная строка s2 - заданное слово идея проста: мы проходим по заданной строке и копируем подстроку, начиная с символа i, с количеством символов, равным количеством символов заданного слова. например: символьная строка: 34строка3254строка заданное слово: строка мы просто берём и проходим циклом 34строка3254строка 3 4строка3254строка 34 строка3254строка и т.д. до самого конца. если рассматриваемая нами подстрока равна заданному слову, то мы увеличиваем счётчик k на 1, после завершения цикла мы просто возвращаем значение нашего счётчика - количество вхождений заданного слова в строку. p.s. мы идём циклом не от 1 до length(s), а от 1 + l1 - l2. к примеру в нашей строке нет смысла рассматривать подстроку, начиная отсюда 34строка3254с трока т.к. символов в ней явно меньше чем в самом заданном слове, следовательно, дальше оно нам уже не попадётся: ) исходный код в приложении.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая, запросив число n, печатала бы числа от 1до n в обратном порядке.
Ваше имя (никнейм)*
Email*
Комментарий*