moskwa999
?>

Нужно расписать как в паскале: составить программу вывода на экран квадратов чисел от 1 до 10. (100 должна быть последняя цифра)

Информатика

Ответы

iservice38
Program a; var i: integer; begin for i: =1 to 100 do writeln(i*i); end.
Arsen0708

1. научиться организовывать ввод и вывод одномерного массива.

2. осуществлять типовые действия над одномерными массивами (подсчет суммы, произведения элементов массива и т. д).

3. осуществлять поиск в массиве (максимального элемента, минимального элемента, элемента с заданными свойствами).

4. осуществлять перестановки элементов в массиве.

программное обеспечение:   pascal (tp или bp), или abcpascal, или freepascal.

аппаратное обеспечение:   эвм типа ibm.

порядок выполнения работы

1. записать тему и цель лабораторной работы.

2. ознакомиться с краткими теоретическими сведениями по теме лабораторной работы.

3. ответить на контрольные вопросы (ответы на контрольные вопросы оформить в отчет).

выполнить практическую часть работы.

№1. обработка одномерных массивов.

№2_обработка 2-х массивов

оформить отчет о проделанной работе. к одной любой разработать блок-схему.

6. защитить работу и сдать ее преподавателю.

контрольные вопросы

1. что такое массив? какие виды массивов вам известны.

2. пример описания одномерного массива.

3. что называют элементом массива? элементы какого типа может содержать массив? сколько элементов может содержать массив?

4. что называют индексом элемента массива? какие типы данных допустимы для индексов элементов массива? сколько индексов может быть у одного элемента массива?

5. какие из описаний одномерных массивов являются не правильными и почему?

a) var a: array[1..20] of integer; b) var sd: array[1..3.5] of integer; c)var a: array[-6..20] of char; d) var dd: array[1] of integer;

6. сколько элементов в каждом из следующих массивов

a) var mb: array[2..20] of integer; b)var myarray2[-5..5] of real;

7. дан одномерный целочисленный массив а из пяти элементов:

dm1trviktor585
Const n=10; var a: array[1..n] of real; max,min: real; i: integer; begin randomize; for i: =1 to n do begin   a[i]: =10*random;   write(a[i]: 5: 1);   end; writeln; max: =a[1];   min: =a[1];   for i: =2 to n do   begin   if a[i]> max then max: =a[i];   if a[i]< min then min: =a[i];   end; writeln('max = ',max: 4: 1,'   min = ',min: 4: 1); end. пример:   3.1   7.4   3.9   2.4   3.1   7.5   1.1   4.1   7.3   9.9 max =   9.9   min =   1.1

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно расписать как в паскале: составить программу вывода на экран квадратов чисел от 1 до 10. (100 должна быть последняя цифра)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

catmos
milkline-nn
s9152992722344
thebest59
samiramoskva
superkiosk249
Егоркина
nsn-2012
gorbunova188
iptsr4968
Seid-ZadeNadezhda1769
Chopper-hinter25
cmenick29
infooem
Konstantinovna1936