Pervosha
?>

1. опишите данный пример на языке паскаль. b= a+10 a) a+10: b b) b: =a+10 c) b: =a+b d) a: =b+10 2. for…to… do какие операторы? a) условное копирование b) безусловное копирование c) условная смена цикла d) известное значение повторяющегося цикла 3. к какому типу относится оператор real? a) целый b) логический c) действительный d) строковый 4. к чему равна значение х? х: =4; while x1; a) 4 b) 8 c) 12 d) 16 5. с какого периода начали использовать язык программирования паскаль? a) 1981 - 1980 b) 1968 - 1971 c) 2000 - 2006 d) 1970 - 1971

Информатика

Ответы

Batrakova-Anna

1)  x = -10, y1 = 100, y2 = -11

2)  x = -9, y1 = 81, y2 = -9

3)  x = -8, y1 = 64, y2 = -7

4)  x = -7, y1 = 49, y2 = -5

5)  x = -6, y1 = 36, y2 = -3

6)  x = -5, y1 = 25, y2 = -1

7)  x = -4, y1 = 16, y2 = 1

8)  x = -3, y1 = 9, y2 = 3

9)  x = -2, y1 = 4, y2 = 5

10)  x = -1, y1 = 1, y2 = 7

11)  x = 0, y1 = 0, y2 = 9

12)  x = 1, y1 = 1, y2 = 11

13)  x = 2, y1 = 4, y2 = 13

14)  x = 3, y1 = 9, y2 = 15

15)  x = 4, y1 = 16, y2 = 17

16)  x = 5, y1 = 25, y2 = 19

17)  x = 6, y1 = 36, y2 = 21

18)  x = 7, y1 = 49, y2 = 23

19)  x = 8, y1 = 64, y2 = 25

20)  x = 9, y1 = 81, y2 = 27

21)  x = 10, y1 = 100, y2 = 29

22)  x = 11, y1 = 121, y2 = 31

Объяснение:

Программа написана на DevC++.

lenarzhaeva
Эм, ищем сумму элементов которые меньше первого и первого var       k, m: integer;       dat: array[1..10] of integer; begin       dat[1] : = 45; dat[2] : = 55;       dat[3] : = 40; dat[4] : = 15;       dat[5] : = 20; dat[6] : = 80;       dat[7] : = 35; dat[8] : = 70;       dat[9] : = 10; dat[10] : = 45;             m : = dat[1];       for k : = 2 to 10 do               if dat[k] < dat[1] then                       m : = m + dat[k];       write(m); end. вывод 165

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. опишите данный пример на языке паскаль. b= a+10 a) a+10: b b) b: =a+10 c) b: =a+b d) a: =b+10 2. for…to… do какие операторы? a) условное копирование b) безусловное копирование c) условная смена цикла d) известное значение повторяющегося цикла 3. к какому типу относится оператор real? a) целый b) логический c) действительный d) строковый 4. к чему равна значение х? х: =4; while x1; a) 4 b) 8 c) 12 d) 16 5. с какого периода начали использовать язык программирования паскаль? a) 1981 - 1980 b) 1968 - 1971 c) 2000 - 2006 d) 1970 - 1971
Ваше имя (никнейм)*
Email*
Комментарий*
▲