shutovaa3471
?>

Составить программу вычисления корней квадратного уравнения поь даным значениям его коффицеент

Информатика

Ответы

platan3698952
Program tt; var   a,b,c,d,x1,x2: real; begin      writeln ('введите коэффициенты: a b c');       readln(a,b,c);       d : = b * b - 4 * a * c; if d > 0 then begin x1 : = (-b + sqrt(d)) / (2 * a); x2 : = (-b - sqrt(d)) / (2 * a); writeln (x1,' ',x2); end else  if d = 0 then begin x1 : = b   / (2 * a); writeln (x1); end else writeln ('корней нет'); end.      
mnogomams47
Написали бы язык программирования хотя бы. вот вам на java ^_^ import java.io.bufferedreader; import java.io.inputstreamreader; public class prog{   public static void main(string[] args) throws exception{   bufferedreader reader=new bufferedreader(new   inputstreamreader(system.in));   system.out.println("введите гипотенузу: ");   int c=integer.parseint(reader.;   system.out.println("введите длину катета: ");   int a=integer.parseint(reader.;   double b=math.sqrt(c*c-a*a);   double p=a+b+c;   system.out.println("периметр: "+p);   double s=(a*b)/2;   system.out.println("площадь: "+s); }}
ldfenix87
Var   count, i, d1, d2, d3, d4, d5, d6: integer; const   min = 189980;   max = 205505; begin   count : = 0;   for i : = min to max do       begin           d1 : = i div 100000;           d2 : = i mod 100000 div 10000;           d3 : = i mod 10000 div 1000;           d4 : = i mod 1000 div 100;           d5 : = i mod 100 div 10;           d6 : = i mod 10;           if ( (d6 * 100000) + (d5 * 10000) + (d4 * 1000) + (d3 * 100) + (d2 * 10) + d1 ) = i          then               count : = count + 1;       end;   writeln('в промежутке от ', min, ' до ', max, ' ', count, ' счастливых билетов'); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу вычисления корней квадратного уравнения поь даным значениям его коффицеент
Ваше имя (никнейм)*
Email*
Комментарий*