ЮлияНиколаевна1748
?>

Сколько чисел нужно взять в последовательности : 1+2+3+. чтобы получилось число, больше чем n? при n=252 нужно взять 23 числа программа + блок-схема.

Информатика

Ответы

Azarova Anastasiya1707
Program zadbl; uses crt; var  a,b,c,i,s: integer; m: array[1..30] of integer; begin  s: =-1;   for i: =1 to 30 do   begin  m[i]: =random(100);   write(m[i]: 3);   end;   for i: =1 to 28 do   begin    if m[i]+m[i+1]+m[i+2]> s then   begin    a: =m[i];     b: =m[i+1];     c: =m[i+2];     s: =a+b+c;     end;     end;     writeln('   a   b   c');     write(a: 3);     write(b: 3);     write(c: 3);     readln; end.
printdecor
Могу накинуть мыслей: когда информация передается по открытым каналам, она может подвергнутся перехвату, многих такая ситуация не устраивает, и не многие принимают меры, а именно: начинают использовать зашифрованный канал между двумя собеседниками(вроде можно и большее кол-во пользователей). хакер - ева, объект отправки - маша, объект приёма - коля. маша кодирует информацию(шифрует) -> отправляет коле |подключается ева (пытается прочитать инфу, а она собака зашифрована, у евы нету ключа (алфавита) дешифровки, она осталась с дыркой от бублика)| -> коля получил инфу (расшифровал заранее полученным по почте или через пересылку ключём (алфавитом), остался рад, он получил любовное послание, никто его не перехватил

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Сколько чисел нужно взять в последовательности : 1+2+3+. чтобы получилось число, больше чем n? при n=252 нужно взять 23 числа программа + блок-схема.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

olgavbaranova
thedoomsdatdcs36
igor-790
maxim-xx38
Daletskaya Sergei1121
krutikovas
nkochladze
lebedev815
Aleksandrovna1153
Vika-simonenko
vtarasyuk
teregorka1977205
Rjkjneirbyf555
ngoncharov573
Liliya_Ivanova