kayrina
?>

Составить программу для вычисления суммы четных чисел натурального ряда от 1 до 100

Информатика

Ответы

dzo-dzo
Var s, k: integer; begin s: =0; for k: =1 to 100 do if k mod 2=0 then s: =s+k; write('сумма четных чисел данного ряда равна ', s); end.
mariokhab
Var  a: array[1..1000] of longint;   n,i,k: longint; begin   readln(n);   for i: =1 to n do read(a[i]);   if odd(a[1]) then k: =1 else k: =2;   for i: =2 to n do   begin   if (odd(a[i]))and(k=1) then   begin     writeln('no');     halt;   end;   if (not odd(a[i]))and(k=2) then   begin     writeln('no');     halt;   end;   if k=1 then k: =2 else k: =1;   end;   writeln('yes'); end.
Tarapovskaya
Матрица не может быть прямоугольной так иначе будет не понятно что подразумевается под диагональю #include< iostream> #include< vector> int main() { int n; std: : cin> > n; std: : vector< std: : vector< int> > matrix(n); for (int i =0; i< n; ++i) {     for (int j =0; j< n; ++j) {           int elem;           std: : cin> > elem;           matrix[j].push_back(elem);     } } int first_diag = 0; int second_diag = 0; for (int i = 0; i< n; ++i) {     first_diag+=matrix[i][i];     second_diag += matrix[i][n-i-1]; } int res = 0; res = first_diag - second_diag; std: : cout< < res; }

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу для вычисления суммы четных чисел натурального ряда от 1 до 100
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Galkin683
vera-sherepa231
julichca68
sv-opt0076
mukbidc
osipov1984osipov
anton1969026203
Алина1564
Андреевнатест707
Lenuschakova1982316
Natysya7777
NIKOLAI
grigoriev8
coffeenik20233
horizma609