Объяснение:
#include <iostream>
#include <math.h>
using namespace std;
int main()
{
double x;
cout<<"Input number x in radian ";
cin>>x;
cout<<"\n cos(x) = "<<cos(x);
return 0;
}
///
#include <iostream>
#include <math.h>
using namespace std;
int main()
{
double x;
cout<<"Input number x in radian ";
cin>>x;
double y1 = cos(x);
if (y1 < 0) cout<<"cos(x)<0, корень вычислиь нельзя";
else
{
cout<<"\n корень(cos(x)) = "<<sqrt(y1);
}
return 0;
}
//
#include <iostream>
using namespace std;
int main()
{
double summ = 0;
for (int i = 10;i<2002;i++)
{
summ += i;
}
cout<<"Сумма равна "<<summ;
return 0;
}
//
#include <iostream>
using namespace std;
int main()
{
int x;
cout<<"Введети отрицательное целое число x ";
cin>>x;
int summ;
for (int i = 0;i<=abs(x);i++)
{
summ += (-i);
}
cout<<"Сумма равна "<<summ;
return 0;
}
1.Блок-схема - это наглядное графическое изображение алгоритма с элементами словесной записи, при котором отдельные действия (этапы) алгоритма изображаются при различных геометрических фигур (блоков), а связи между этими этапами указываются при стрелок, соединяющими эти фигуры.
2.Блок движение
Блок – звук.
Блок – внешность.
Блок контроля.
Блок сенсоры.
Блок числа.
Блок перо.
Блок переменные
Их очень много в программе например я показал скретч.
3 пример линейного алгоритма:
начало
ввод а,б
c := a+b
пример циклинического алгоритма во
вложении
Там есть изображение.
4.Вродебы нет
5.Циклические алгоритмы бывают двух типов: Циклы со счетчиком в которых какие-то действия выполняются определенное число раз: Циклы с условием в которых тело цикла выполняется в зависимости от какого-либо условия.
6.на етот вопрос незнаю ответ сории
Поделитесь своими знаниями, ответьте на вопрос:
Даны 3 числа a, b, c.определите сколько из них отрицательных. сделайте блок схему что надо вводить в программу