Takhmina-Komarova1415
?>

Нужно написать программу на паскале. вычислить среднеарифметическое четных элементов массива c(10), не меньших 10

Информатика

Ответы

demon8608
Var c: array[1..10] of integer; srar: real; k, i, s: integer; begin s: =0; {обнуляем счетчик элементов(к) и сумму(s)} k: =0; randomize; for i: =1 to 10 do {заполняем массив}   c[i]: =random(50); for i: =1 to 10 do   if (c[i] mod 2=0) and (c[i]> 10) then {если элемент массива четный и больше 10 увеличиваем счетчик к, увеличиваем сумму s}      begin     k: =k+1;       s: =s+с[i];     end; srar: =s/k; for i: =1 to 10 do {выводим массив} write(c[i], ' '); writeln; writeln('sr.arifmeticheskoe=', srar: 5: 2); end.
cutur3414

Авторское пра́во — в объективном смысле — институт гражданского права, регулирующий правоотношения, связанные с созданием и использованием (изданием, исполнением, показом и т. д.) произведений науки, литературы или искусства, то есть объективных результатов творческой деятельности людей в этих областях.

Виды авторских прав.

Право авторства – право признаваться автором произведения Право на имя – право указывать свое имя или псевдоним на экземплярах произведения Право на неприкосновенность произведения – право запрещать любые изменения произведения без согласия автора

Подробнее - на -

diana8

Was a young man in love with a beautiful girl? What did the girl say to the young man one day? Where did a young man go? How old was the girl? How many roses did a man in the shopsencl?

Дополнен менее минуты назад

молодой человек был влюблен в красавицу. они очень часто встречались и много времени проводили вместе. они говорили об интересных книгах, фильмах о театральной работе. однажды девушка сказала молодому человеку: - завтра у меня день рождения. Вы придете, чтобы отпраздновать его с другими друзьями? -О, Конечно сказал молодой человек. - Но сначала я пришлю вам розы, - сказал один из продавцов, - чтобы вы послали их девушке на следующий день. Человек в магазине знал молодого человека очень хорошо, потому что он часто покупал цветы в своем магазине. ВОТ ПЕРЕВОД .

Объяснение:

Was a young man in love with a beautiful girl? What did the girl say to the young man one day? Where did a young man go? How old was the girl? How many roses did a man in the shopsencl?

Дополнен менее минуты назад

молодой человек был влюблен в красавицу. они очень часто встречались и много времени проводили вместе. они говорили об интересных книгах, фильмах о театральной работе. однажды девушка сказала молодому человеку: - завтра у меня день рождения. Вы придете, чтобы отпраздновать его с другими друзьями? -О, Конечно сказал молодой человек. - Но сначала я пришлю вам розы, - сказал один из продавцов, - чтобы вы послали их девушке на следующий день. Человек в магазине знал молодого человека очень хорошо, потому что он часто покупал цветы в своем магазине. ВОТ ПЕРЕВОД .

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно написать программу на паскале. вычислить среднеарифметическое четных элементов массива c(10), не меньших 10
Ваше имя (никнейм)*
Email*
Комментарий*