Microsoft word в этой прогрраме можно найти символы
prik-galina7390
18.06.2020
Var a: array [1..20] of integer; i, s: integer; begin randomize; s : = 0; for i : = 1 to 20 do a[i] : = random(40) - 10; for i : = 1 to 20 do begin write(a[i], ' '); if (a[i] + 10) mod 2 = 1 then s : = s + 1; end; writeln(); writeln(s); end.
Vasileva
18.06.2020
57 в восьмеричной системе - это в нашей 10-ричной 47. 2014 в шестнадцатеричной - это в нашей 8212. составить алгоритм по нахождению последней цифры при возведении а в степень b не сложно: var i,a,b,p: word; {диапазон целых чисел 0..65535} begin readln(a,b); p: =a mod 10; {первая степень числа а} for i: =2 to b do {если степень больше 1, то в цикле начинаем домножать, пока № витка цикла не дойдет до b } begin p: =p*a; {домножаем результат на последнюю цифру числа а} p: =p mod 10; {отделяем последнюю цифру результата} end; writeln(p); {по окончании цикла в р находится результат } end.в результате вводимых данных (47 и 8212) получаем 1. думаю, что и в 16-ричной будет тоже 1.
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Вблокноте дан текст написать программу которая выводит наиболее часто встречающиеся символы.