Var
N,A:integer;
Begin
Write('N = ');Read(N);
A:=0;
While N>0 do
Begin
if (N mod 10) > A then A:= N mod 10;
N:=N div 10;
End;
Write(A)
End.
Var
N,A,B:integer;
C:boolean;
Begin
Write('N = ');Read(N);
A:=-1;
B:=-2;
C:=false;
While N>0 do
Begin
if A=B then C:=true;
if N>0 then
Begin
A:=N mod 10;
N:=N div 10;
End;
if A=B then C:=true;
if N>0 then
Begin
B:=N mod 10;
N:=N div 10;
End;
End;
if A=B then C:=true;
if C then Write('Есть')
else Write('Нет')
End.
Надсистема-Первая группа решений задачи минимизации связана с использованием надсистемы. Что такое надсистема? Это то, что окружает систему; то, с чем она взаимодействует. Для устройства – это окружающие его другие устройства, которые работают вместе. Так, для плазменной панели в качестве надсистемы может выступать мультимедийный центр, который включает саму плазменную панель, DVD-плеер, игровую приставку, колонки, компьютер. Подсистема- это набор объектов и подсистем, обеспечивающих некоторую функциональность, и взаимодействующих между собой в соответствии с их интерфейсами. Интерфейс подсистемы представляет собой подмножество объединения интерфейсов всех объектов и подсистем, составляющих эту подсистему. В состав подсистемы может входить один, или более взаимозависимых объектов и/или подсистем.
Поделитесь своими знаниями, ответьте на вопрос:
Нужно написать программу в паскале по ветвлениям) ввести последовательно возраст антона, бориса и виктора. определить, кто из них старше. пример: возраст антона: 15 возраст бориса: 17 возраст виктора: 16 ответ: борис старше всех. пример: возраст антона: 17 возраст бориса: 17 возраст виктора: 16 ответ: антон и борис старше виктора. заранее большое)