mursvita943
?>

Cоставить программу в паскале: заданы координаты концов отрезка (x1; y1) и (x2; y2) и два целых числа n1, n2. вычислить координаты точки (х; у), которая делит отрезок в отношении n1/n2: если l=n1/n2, то х=(х1+l*x2)/(1+l) , y=(y1+l*y2)/(1+l

Информатика

Ответы

lugowskayatania2017
Program qq; uses crt; var x1, y1, x2, y2, n1, n2: integer; x, y, l, m, k, b: real; // чтоб было приятно, возьмём координаты начальных точек - целыми числами. begin writeln ('введите координаты первой точки через пробел'); readln(x1, y1); writeln('введите координаты второй токи через пробел'); readln(x2, y2); writeln ('введите через пробел числа n1 и  n2'); readln(n1, n2); l: =n1/n2; //далее производится расчет по формулам, данным в x: =(x1+l*x2)/(1+l); y: =(y1+l*y2)/(1+l); writeln ('координаты искомой точки (',x,'; ',y,')'); end.
elizabetmaslova3
Это одно из свойств алгоритмов: дискретность – процесс решения должен быть разбит на последовательность отдельных шагов. понятность. алгоритм должен быть понятен исполнителю и исполнитель должен быть в состоянии выполнить его команды. определенность. алгоритм не должен содержать команды, смысл которой может восприниматься неоднозначно. результативность. процесс решения должен прекратиться за конечное число шагов и при этом должен быть получен ответ . массовость. по одному алгоритму можно решать однотипные
stepanova-natalie
Using system; // написать программу, выводящую на экран таблицу квадратов // четных чисел от 0 до 10 в убывающем порядке: 100, 81, // составь блок-схему алгоритма, и напиши программу которая // выводит на экране узор, состоящий из звездочек. должно быть 20 строчек со звездочками так, чтобы в каждой последующей строке было на одну звездочку больше. для вывода на экран строки, со- держащей n звездочек, используй команды // string repeatedstring = new string('*', n); console.write (repeatedstring); // microsoft visual studio c# namespace nonamespace {       internal class program {               private static void main() {                       squaresofnumbersdesc();                       stars(20, 10);                       console.readline();               }               private static void squaresofnumbersdesc() {                       console.writeline();                       for (var i = 10; i > = 0; i = i - 2) {                               console.write("{0} ", i * i);                       }                       console.writeline();               }               private static void stars(int n, int start_stars) {                       console.writeline();                       for (var i = 0; i < n; i++) {                               console.writeline(new string('*', start_stars + i));                       }                       console.writeline();               }       } }

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Cоставить программу в паскале: заданы координаты концов отрезка (x1; y1) и (x2; y2) и два целых числа n1, n2. вычислить координаты точки (х; у), которая делит отрезок в отношении n1/n2: если l=n1/n2, то х=(х1+l*x2)/(1+l) , y=(y1+l*y2)/(1+l
Ваше имя (никнейм)*
Email*
Комментарий*