zdl2008
?>

Составьте программу, определяющую, является ли данное натуральное число простым. это паскаль.

Информатика

Ответы

sherifovaelina
Uses crt; var x,i,flag: integer; begin clrscr; writeln("x="); read(x); for i: = 1 to x begin if (x div i )< > 0 then flag: =flag+1; end; if (flag = 2) write("chislo prostoe") else write("chislo ne prostoe"); readln; end.
ирина_Андреевич1634
Основная статья:   вычислительной техники

потребность считать возникала у людей вместе с появлением цивилизации. им было необходимо осуществлять торговые сделки, проводить землемерные работы, запасами урожая, следить за астрономическими циклами. для этого издревле были изобретены различные инструменты, от  счётных палочек  и  абака, в ходе развития науки и техники эволюционировавшие в  калькуляторы  и разнообразные вычислительные устройства, в том числе и персональные компьютеры.

важнейшие этапы развития вычислительной техники до появления персональных компьютеров[править  |  править вики-текст] механические и автоматические вычислительные средства[править  |  править вики-текст] v век до н. э.  —  абак  (счётная доска).1642  —  «паскалина»  блеза паскаля, первая попытка механизировать вычисления.1654  —  логарифмическая линейка, первое устройство, сделавшее вычисления быстрыми и получившее широкое распространение.1801  —  ткацкий станок  жозефа мари жаккара, изобретение  перфокарты.1820-е годы  —  арифмометр  томаса, первое механическое вычислительное устройство, получившее широкое распространение.1822-1838  —  разностная машина чарльза бэббиджа, первая попытка создать программируемое вычислительное устройство. электромеханические вычислительные средства[править  |  править вики-текст] 1888-1890  —  табулятор  холлерита, первое автоматическое вычислительное устройство, производившееся промышленными партиями. впоследствии (1896) герман холлерит основывает компанию  tabulating machine company, в  1924  году переименованную в  international business machines corporation  после промежуточной смены имени в 1911.1937  —  z1, вычислительная машина, разработанная  конрадом цузе, стала первым вычислительным устройством, работавшим на двоичной логике и применявшее  арифметику с плавающей запятой.1943  —  «марк i», первый компьютер, произведённый фирмой  ibm. электронные вычислительные средства[править  |  править вики-текст] 1946  —  eniac;   1948  —  манчестерская мэм «baby»;   1949  —  edsac  — первые  эвм.7 апреля  1964  г. фирма  ibm  объявила о создании семейства компьютеров  system 360  — первой серии масштабируемых компьютеров, впоследствии ставшая примером открытого стандарта, когда один производитель компьютерного оборудования мог произвести оборудование, совместимое с оборудованием другого производителя; широкое распространение system 360 де-факто установило стандарт  байта, состоящего из 8  битов, и ввело в широкое употребление  шестнадцатеричную систему счисления  в программировании. теоретические разработки, нашедшие применение в персональных компьютерах[править  |  править вики-текст] xvii век  — описание  лейбницем  двоичной системы счисления.1847-1854  — изобретение  булевой   на основе двоичной системы счисления.1940-1948  — понимание того, что работа логических электрических схем тождественна булевой и разработка  теории информации  клода шеннона.середина 1940-х  — разработка  архитектуры фон неймана.1957  — впервые реализован  язык программирования высокого уровня, носивший название  фортран.в  1964  г.  американская ассоциация стандартов принимает новый 7-битовый стандарт для обмена информации  ascii  (american standard code for information interchange).в  1964  г.  джон кемени  и  томас курц  в  дартмутском колледже, разработали  язык программирования  basic. этот язык программирования с различными модификациями применялся почти во всех персональных и компьютерах 1970-80-х годов.в  1973  г.  исследовательский центр  xerox parc  представил  xerox alto  — первый в мире образец компьютера с оконным (графическим) интерфейсом. появление технологий, нашедших применение в персональных компьютерах
bulk91675
В40-ходах xx в. сразу несколько групп исследователей повторили попытку бэббиджа на основе техники xx в. — электромеханических реле. некоторые из этих исследователей ничего не знали о работах бэббиджа и переоткрыли его идеи заново. первым из них был инженер конрад цузе, который в 1941 г. построил небольшой компьютер на основе нескольких электромеханических реле. но из-за войны работы цузе не были опубликованы. а в сша в 1943 г. на одном из предприятий фирмы ibm американец говард эйкен создал более мощный компьютер под названием «марк-1». он уже позволял проводить вычисления в сотни раз быстрее, чем вручную (с арифмометра), и реально использовался для военных расчетов.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, определяющую, является ли данное натуральное число простым. это паскаль.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

milaudina
Kotvitskii
Anastasiamoscow80
uglichwatch
elena
elenaowchinik4842
hotel-info
ИванМолчанов
vadimnechaev23150
galinaobraz
Стяжкин
Alekseevna
aguliaeva
vladai2
kazimov832