alekseisamohvolov7
?>

Написать программу: "дано четырехзначное число.что больше: сумма цифр, стоящих на четных местах, или сумма цифр, стоящих на не четных местах? "

Информатика

Ответы

Kochinev4
Var a,s1,s2: integer; begin read (a); if (a> =1000)and (a< =9999)then begin s1: =(a mod 10) + ((a mod 1000) div 100); s2: =(a div 1000) + ((a mod 100) div 10); if (s1> s2)then writeln ('сумма цифр,стоящих на четных местах больше суммы цифр, стоящих на нечетных местах'); if (s1< s2)then writeln ('сумма цифр,стоящих на нечетных местах больше суммы цифр, стоящих на четных местах'); if (s1=s2)then writeln ('сумма цифр,стоящих на четных местах равна сумме цифр, стоящих на нечетных местах'); end else writeln ('вы ввели не 4-ёхзначное число'); end.
ElenaEgorova1988576
Var x,y: real;         begin    writeln('x=');           readln(x);     writeln('y=');       readln(y);       if (x< 0) and (y< 0)   then writeln (abs(x), ' ',abs(y));         if (x< 0) and (y> 0) or (x> 0)  and (y< 0)   then writeln(2*x,' ', 2*y);   if (x> 0) and (y=0) or (x=0) and (y> 0) or (x> 0) and (y> 0) then writeln( sqrt(x),' ',sqrt(y));     readln; end.
tarkhanovilya
Const   n=20; var   a,b: array[1..n] of integer;   i,k,s: integer; begin   randomize;   writeln('массив a');   for i: =1 to n do   begin       a[i]: =random(50)+1;       write(a[i]: 3)   end;   s: =0;   writeln(#13#10,'массив b');   for i: =1 to n do   begin       b[i]: =random(2);       write(b[i]: 3);       if b[i]=1 then s+=a[i]   end;   i: =1;   while (b[i]=0) and (i< =n) do inc(i);   if i> n then k: =0 else k: =i;   writeln(#13#10,'k=',k,', s=',s) end.   тестовое решение: массив a   22 50 34 22 19  1 36  5 23 30 27 24 48 22 24 27 14 14 39  3 массив b   0  1  0  1  0  0  1  1  1  1  0  1  1  1  0  1  1  1  0  1 k=2, s=318

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу: "дано четырехзначное число.что больше: сумма цифр, стоящих на четных местах, или сумма цифр, стоящих на не четных местах? "
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Evsevia-a
strelnikov-aa
pavlino-mkr
koeman
Anatolevich1506
cholga69
геннадиевна2001
впвыпвып-Зуйков629
fedorenkoroman
Borg Fedak1162
ashkiperova6
aeykin
dionissia2
jaksonj326
Erikhovich