Aleksei1463
?>

Сделать по информатике. необходимо сделать на языке и на паскале (желательно с объяснениями 2. все натуральные числа, начиная с 1, выписаны в одну строку без пробелов.требуется написать программу, определяющую, какая цифра стоит в этой строке на заданном месте. технические требования. имя входного файла: input.txt имя выходного файла: output.txt формат входных данных: в единственной строке входного файла записано целое число n - длина слова (1 ≤ n≤ 100000000). формат выходных данных: выходной файл содержит одну искомую цифру. примеры файлов входных данных: примеры файлов выходных данных: 21 5

Информатика

Ответы

ipaskarovanv6

думаю так.

входной файл input.txt

выходной файл output.txt

ограничение времени 5 секунд

 

пусть  sn=cos(an-cos(an-1+cos(an-2-cos(an-3+…)…).

пусть  an=(…(x+2)x+3)x+4)x+…+n)x+n+1.

требуется для заданных  n  (1< =n< =200)  и  х=1  напечатать выражение, определяющее  sn

в единственной строке  входного файла  задано  n.

в единственной строке  выходного файла  должно содержаться искомое выражение, затем без пробела знак равно и значение выражения с точностью до четырех знаков после точки.

пример входного файла:

5

пример выходного файла:

+2)x+3)x+4)x+5)x+6-+2)x+3)x+4)x+5++2)x+3)x+4-cos((x+2)x+3+cos(x+=-0.4637

AkulovaAnastasiya
#include < iostream> #include < math.h> using namespace std; class numhandler { int number; public: numhandler(int n): number(n) {} int getdigitcount() { int ret = 1, tested = 1, div; while (true) { div = (int) number / tested; if (div == 0) { return ret - 1; } else { ret++; tested *= 10; } } } int getdigitsum() { int ret = 0, tenmult = pow(10, getdigitcount() - 1), div; while (tenmult > = 1) { div = (int) number % (tenmult * 10) / tenmult; ret += div; tenmult /= 10; } return ret; } int getlastdigit() { return number % 10; } }; int main() { int num; cout < < "n = "; cin > > num; numhandler handler(num); cout < < endl; cout < < "число цифр: " < < handler.getdigitcount() < < endl; cout < < "сумма цифр: " < < handler.getdigitsum() < < endl; cout < < "последняя цифра: " < < handler.getlastdigit() < < endl; return 0; }
Valentinovna
  program al;   var   a: array[1..32000] of integer;   buf: integer;     i,n,min,max: integer; begin    writeln('n=');     readln(n);     writeln('vvedite massiv=');     for i : = 1 to n do    readln(a[i]);     min: =1;   max: =1;   for i: =2 to n do      begin      if a[min]> a[i] then        min: =i;         if a[max]< a[i] then          max: =i;       end;   buf: =a[min];   a[min]: =a[max];   a[max]: =buf;     writeln('massiv posle obmena max< -> min');     for i: =1 to n do      write(a[i]: 4);   writeln;   end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Сделать по информатике. необходимо сделать на языке и на паскале (желательно с объяснениями 2. все натуральные числа, начиная с 1, выписаны в одну строку без пробелов.требуется написать программу, определяющую, какая цифра стоит в этой строке на заданном месте. технические требования. имя входного файла: input.txt имя выходного файла: output.txt формат входных данных: в единственной строке входного файла записано целое число n - длина слова (1 ≤ n≤ 100000000). формат выходных данных: выходной файл содержит одну искомую цифру. примеры файлов входных данных: примеры файлов выходных данных: 21 5
Ваше имя (никнейм)*
Email*
Комментарий*