ganna1790
?>

Даны стороны треугольника abc определить является ли треугольник равнобедренным.напишите программу на паскале

Информатика

Ответы

leobashkurov1089
Var a,b,c: integer; begin read(a,b,c); if (a=b) or (b=c) or (a=c) then writeln('треугольник равнобедренный') else writeln('треугольник не равнобедренный'); end.
Filintver
//pascalabc.net версия 3.2, сборка 1367 begin       var sum : = 0;       for var i : = 1 to readinteger('n=') do       begin               var num : = readinteger('введите число =');               if num..count(c -> c = '5') = 2 then                       sum += num;       end;       writeln(sum); end.
nadyatsoi
========== 1 вариант через строку ========== var    n,a,k,sum,i,j: integer;     s: string;   begin   sum: =0;     write ('введите количество чисел: ');   readln (n);   for i: =1 to n do begin      write ('введите число: ');     readln (a);     str(a,s);     k: =0;     for j: =1 to length(s) do        if s[j]='5' then k: =k+1;     if k=2 then sum: =sum+a;   end;     writeln ('sum = ',sum); end. ========== 2 вариант через div и mod ========== var    n,a,x,k,sum,i: integer;   begin   sum: =0;     write ('введите количество чисел: ');   readln (n);   for i: =1 to n do begin      write ('введите число: ');     readln (a);     x: =abs(a);     k: =0;     while x> 0 do begin       if x mod 10 =5 then k: =k+1;       x: =x div 10;     end;     if k=2 then sum: =sum+a;   end;     writeln ('sum = ',sum); end. ========== пример результата: ========== введите количество чисел: 3 введите число: 550001 введите число: -550000 введите число: 123456 sum = 1

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Даны стороны треугольника abc определить является ли треугольник равнобедренным.напишите программу на паскале
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

NarekAlekseevich779
izumrud153
Ольга тимур
dokmak140652
Zolotnik974620
kuz-vlad21
ПетросовичЗаславский
armsam76
maryshecka
kseniay2006548
tany821
suturinavaleriya51
prik-galina7390
Vrpeshka
andreyshulgin835