1 дан массив из n элементов (n > = 4). подсчитать среднюю арифметическую второго и предпоследнего элемента массива. 2). дан массив из n элементов. написать программу подсчитывающую произведение элементов массива.
Var a: array[1..50000] of integer; n,i,p: integer; sr: real; begin readln(n); p: =1; for i: =1 to n do begin read(a[i]); p*=a[i]; end; sr: =(a[2]+a[n-1])/2; writeln('среднее ар. - ',sr: 2: 1,' произведение - ',p); end.
Носов Тоноян
20.03.2023
Const handsfree = false; nmax = 31; random_min = -20; random_max = 30; var a: array[1..nmax] of real; i, n, j: integer; k: integer; begin {ввод массива} if handsfree then n : = random(nmax - 5) + 5 else begin write('n = '); readln(n); end; writeln('данные массива: '); for i : = 1 to n do begin if handsfree then begin a[i] : = random(random_max - random_min) + random_min; write(a[i], ' '); end else readln(a[i]); end; writeln(); {подсчет элементов} k : = 0; for i : = 1 to n do if a[i] = 15 then k : = k + 1; writeln('quantity = ', k); end.